Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Thermopile voltage drops when try to turn heater on. Main flame not firing up.

michaelbevanmichaelbevan Member Posts: 2
Hello

I couldn’t find an answer to this, but perhaps I didn’t find the right phrasing.

I have a gas log heater. A Matrix GFX-S. Might be an Australian rebrand.

I couldn’t get the main flame to fire up. I checked the thermopile voltage and it was initially showing about 90mv. I gave it a good clean and it now shows around 800mv, but drops right back to about 50mv when I press the on button. It’s possible that the heater was switched to on when I initially tested prior to cleaning the thermopile. The main flame still won’t ignite.

Any ideas as to how I can get my heater working again?

Any responses much appreciated.

Michael 😊

Comments

  • Jamie HallJamie Hall Member Posts: 12,954
    Check and recheck all the electrical connections. Even the slightest extra resistance can do that. Thermopiles don't have much "oomph". It might also be the gas valve drawing too much current.
    Br. Jamie, osb

    Building superintendent/caretaker, 7200 sq. ft. historic house museum with dependencies in New England.

    Hoffman Equipped System (all original except boiler), Weil-Mclain 580, 2.75 gph Carlin, Vapourstat 0.5 -- 6.0 ounces per square inch
  • EdTheHeaterManEdTheHeaterMan Member Posts: 636
    if you have enough power to maintain the pilot, but the main valve draws too much current, it is most likely the gas valve. But I would go for checking the connections first, (no cost for parts) then replace the thermopile, (less expensive than the replacement valve). If that does not work then the valve.

    I always ask the mechanics that worked for me when the condemn an expensive part... "After you replace that and it still does not work, what will you check next?"

    they usually suggest some less expensive repair, then I say...
    "Do that first!"

    This brings me to the conclusion that the pilot may not be large enough to generate the necessary current. Is the Pilot Burner Clean?
  • michaelbevanmichaelbevan Member Posts: 2
    Thank you so much for your answers Ed and Jamie.😊

    I tried your suggestions, then went out and bought a new thermopile. What do you know!

    The heater is working again. Woo hoo!
  • mattmia2mattmia2 Member Posts: 1,443
    Can you check the current that the gas valve is drawing with an ordinary milliammeter, or does the shunt add too much resistance or is the current to low to measure?
  • ratioratio Member Posts: 2,496
    Google the thermopile & gas valve & see what's expected. ISTR that thermopiles were millivolts x amps, & thermocouples were volts x milliamps, so a milliammeter might not be the right instrument for your case.
  • Tim McElwainTim McElwain Member Posts: 4,374
    edited July 4
    You need to check the millivolts for the system. Contact me at [email protected] and I will send you the step by step procedure. It would also help me to help you if you have pictures of pilot and gas valve along with other components in the system.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!