Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Taco Zone Control Switch Relay Box - Zone 1 of 2 is out - try switching fuses?

Jonesey
Jonesey Member Posts: 8
edited October 2017 in Radiant Heating

Hello all,
I have a question for the Taco Zone Control Box experts. I have a two zone PEX radiant system on a gas fired boiler Weil McClain CGa. Zone 2 works fine, the problem is with Zone 1. When the T-Stat for Zone 1 calls for heat, the little red LED on the side of Taco Box does not light and I DO NOT get 120V for the Zone 1 terminals, I get 0.0 V; hence no heat. Interestingly, I do have ~ 24V coming into the Zone 1 T Stat terminals, so to me, it seems like the box is simply not relaying the signal to send 120V to the boiler for Zone 1.
I am inclined to try replacing the fuse for Zone 1 (there are replacement fuses on the the lower right side of the board) but I'm not sure how to do that.
What do you think? Thank you for any help, I appreciate it!
Image

Comments

  • STEVEusaPA
    STEVEusaPA Member Posts: 5,180
    Turn off power.
    First check would be to remove the thermostat wires for zone 1. Jump t-t on zone one, turn on power and see if red light comes on.
    If not, I would then look at fuses and the cube relay.
    steve
    Zman
  • Jonesey
    Jonesey Member Posts: 8

    Turn off power.
    First check would be to remove the thermostat wires for zone 1. Jump t-t on zone one, turn on power and see if red light comes on.
    If not, I would then look at fuses and the cube relay.

    Thank You Steve. When you say "Jump t-t" I assume you mean the terminals?
  • STEVEusaPA
    STEVEusaPA Member Posts: 5,180
    Yes I get a little nervous trying to talk someone thru electrical diagnosis, because one slip and if your lucky, you get to buy a new one. If you're not...
    That's why I told you to turn off power first.
    If you're not comfortable diagnosing this you should call for help, but it's pretty easy.
    steve
  • Jonesey
    Jonesey Member Posts: 8
    I understand the trepidation Steve and appreciate it. Anyway, I had some success with getting the Taco to start Zone 1 and the zone 1 pump. After checking the relays and fuses, I simply switched the thermostat wires from Zone 2 to Zone 1's terminal and Zone 1 fired up. It worked fine but I'm worried b/c I did notice that the boiler pump was not running while zone 1's pump was running. Not sure if the boiler pump is supposed to run whenever a zone pump is running on a Weil McClain CGa but anyway, I'll get a new thermostat tomorrow and switch back the thermostat wires to where they were. Thanks for any and all help - I appreciate it.