Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Baxi Luna 3 Comfort - thermostat issues

Options
I dropped our thermostat when I was changing the batteries. A couple of the connections on the back of the unit broke, so I purchased a new thermostat. I installed the new thermostat, but it is not working.

There is a control unit on the front of the boiler that has a built-in thermostat(you can see it in this Baxi pdf) - I believe the boiler is using the temperature from that thermostat to determine if heat is needed instead of the remote thermostat. If the temp drops below the threshold set on the control unit, the heat will come on. The boiler is still working to heat water as it should.

As a last ditch attempt to get it working, I did purchase another thermostat that is exactly like the one I broke. Still can't get it to work.

I would greatly appreciate any help/advice you can offer to get this running correctly.

Comments

  • Jamie Hall
    Jamie Hall Member Posts: 23,656
    Options
    Check and make sure all the wiring connections are secure and, if the thermostat is the sort which has connecting pins on it which go into a socket or onto pads on the wall plate, that those pins and the wall socket or pad connections are in good condition.
    Br. Jamie, osb
    Building superintendent/caretaker, 7200 sq. ft. historic house museum with dependencies in New England
  • Derheatmeister
    Derheatmeister Member Posts: 1,572
    Options
    If this control is like the QAA 73 from the 1.33/330 Baxi then you may need to programm/Enable the Thermostat function on the remote diplay in order for it to work.
    EdTheHeaterMan
  • HikingGeek
    HikingGeek Member Posts: 2
    Options
    @Jamie Hall - thanks. both thermostats are new, so the pins are in good condition.

    @Derheatmeister - your reply resulted in me finding this video: Programming a BAXI Luna 3 Boiler for External Thermostat

    it works now. THANK YOU!
    EdTheHeaterMan