Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

New WM 1013-200 controller on old GV 4 Series 1 boiler. Limit light flashing

Options
Steve Garson_2
Steve Garson_2 Member Posts: 712
edited May 2023 in THE MAIN WALL
I just replaced the controller on my boiler, which has solved the issue that I've had. But the limit LED flashes continuously, an LED that did not even exist on the old controller. But the boiler works as it should.

How does the controller have any signaling from the limit switch? Should I simply ignore this?
Steve from Denver, CO

Comments

  • HVACNUT
    HVACNUT Member Posts: 5,875
    edited May 2023
    Options
    Did you order the new control for your Series GV? I had that a while back. The supplier hit the wrong button on the keyboard and sent one for a Series 3 when I needed one for a Series 2, or similar to that. It was visually different. I didn't even try to install it. The point being, there are different controls depending on the Series.
  • EdTheHeaterMan
    EdTheHeaterMan Member Posts: 8,157
    edited May 2023
    Options
    You are not the first one the have this happen https://forum.heatinghelp.com/discussion/132369/wm-1013-200-troubleshooting
    I think you are ok to operate but you may want to get the part suggested to stop the flashing Limit

    Page 71 and 72 have the trouble shooting for this control https://www.weil-mclain.com/sites/default/files/field-file/gv-series-4-manual_1.pdf

    Edward Young Retired

    After you make that expensive repair and you still have the same problem, What will you check next?

    Steve Garson_2
  • 109A_5
    109A_5 Member Posts: 1,388
    Options
    Hello @Steve Garson_2,

    The controller is unhappy but not unhappy enough to not let the Boiler work. Is this sensor missing (item 27) since your boiler is older ?







    National - U.S. Gas Boiler 45+ Years Old
    Steam 300 SQ. FT. - EDR 347
    One Pipe System
  • Steve Garson_2
    Steve Garson_2 Member Posts: 712
    Options
    Problem solved! There was a small part that was not mentioned in the instructions that I plugged into an empty molex connector.
    Steve from Denver, CO
    EdTheHeaterManCastle