Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Steam Boiler short cycles...30 seconds or less

appletaxiappletaxi Member Posts: 2
30 yr old residential one pipe steam boiler system.
Turning on and off constantly.
Some times the burners do not get fully lit before turning off.
A slight gas smell from the burners not fully lighting.

Ideas??

Comments

  • Jamie HallJamie Hall Member Posts: 12,724
    Almost certainly a controls problem, probably in the ignitor or flame detector or gas valve. But which one? Unless you are very comfortable troubleshooting, might be a good time to get a qualified gas burner tech. in to take a look? And maybe clean the boiler and adjust everything while he or she is at it?
    Br. Jamie, osb

    Building superintendent/caretaker, 7200 sq. ft. historic house museum with dependencies in New England.

    Hoffman Equipped System (all original except boiler), Weil-Mclain 580, 2.75 gph Carlin, Vapourstat 0.5 -- 6.0 ounces per square inch
  • JUGHNEJUGHNE Member Posts: 6,797
    The first thing that comes to mind is the flame sensor.
    It is a metal rod that has to be in the pilot flame to keep the gas valve on. Often simple cleaning will fix your problem.

    Can you see the pilot/igniter assembly mounted on the burners?
    A picture of it and also the control module might help.
  • appletaxiappletaxi Member Posts: 2
    Technician found the the Low Water Sensor was gunked up. Drained system and cleaned. Running fine now.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!