Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

HTP Elite 1st Gen FO6, then FO3, replaced return sensor, still F03

wcs5050wcs5050 Member Posts: 126
edited May 2019 in THE MAIN WALL
Went from erratic operation to none. Resistance across original return thermister dancing but seems ok. Anyone have any ideas. Primary pump operational.

Comments

  • wcs5050wcs5050 Member Posts: 126
    Skip that... Went back for followup eval... Not obvious, but flue gas temperature sensor under upper cover snapped and was sending vapor and moisture over upper control board. Integrated relay on board faulted.
  • TimcoTimco Member Posts: 2,969
    Hello,

    We have a TSB regarding this issue, and if you email us at [email protected] or call us at 800-323-9651 we can send you the entire kit needed (7450P-901) to replace the exhaust flue assembly and the flue temp sensor. Sorry to hear you had this issue. I only check in every 2-3 days so I missed this post. Tim
    Just a guy running some pipes.
    ratio
  • Le JohnLe John Member Posts: 175
    Hats off to HTP and @Timco for providing Excellent Customer Service!
    Timcoratio
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!