Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Furnace won't light off

happyseniorhappysenior Posts: 2Member
My S8610U module will not give my gas valve 24vac to.open the gas to the burners ? Pilot on.

Comments

  • DZoroDZoro Posts: 902Member
    Need some more information. Pictures would help.
    D
  • happyseniorhappysenior Posts: 2Member
    its on a coleman mobilehome furnance #7600 that has a new honeywell pilot retrofit kit Y8610U....Just installed a new module,as one I got with kit failed. It worked good for a week and just quit.😪it works for a few days,then quits.😿
    Furnace is over 30 Yrs old.! Should I take burner out and clean good ? Just put in new blower motor.pilot light works good...
  • DZoroDZoro Posts: 902Member
    Very possible you may have 1: bad heat exchanger or 2: Rusted chimney vent and intake piping.
    Does it light the burner and then a few seconds later flame goes out?
    D
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!