Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

No heat, Taco ZVC404 only power light on

The heat was not coming on per my wife. Propane Crown Boiler (18 years old), Taco ZVC404(4 zone but I only use two, two story cape house) 1st floor thermostat calling for heat, but the only light on is the power light on the ZVC. So I turn breaker to furnace off, turn down thermostat on first floor, turn second floor thermostat up, and turn furnace breaker back on. Now have everything working, both zones.

What happened? What is going to go wrong when it is -20 degees?

Comments

  • unclejohn
    unclejohn Member Posts: 1,757
    Sounds like you were not getting a signal from the first floor tstat.
  • Zman
    Zman Member Posts: 7,328
    What kind of t-stat do you have? Those zone relays are pretty simple and reliable. I would suspect a thermostat or wiring issue.
    "If you can't explain it simply, you don't understand it well enough"
    Albert Einstein
  • Wellness
    Wellness Member Posts: 126
    edited November 2018
    2nd @Zman. Is thermostat one of those fancy battery operated ones? It maybe dead or almost depleted of power, thus no signal to Taco. If not, probably a wiring issue.
  • Angel123834
    Angel123834 Member Posts: 2
    Your right, it is a fancy battery one. I will check connections. Thanks for the help.
  • delta T
    delta T Member Posts: 870
    replace the batteries in the stat if you have not done it recently. The display can still work, while the stat does not have enough juice to close the relay and send a signal to the ZVC.