Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Navien combi CH240 ASME - repeated E002 and E011 water pressure error codes

Options
EraGem
EraGem Member Posts: 2
edited November 2017 in THE MAIN WALL
Hello, I've had my Navien CH-240 ASME for about 4 years and have been sporadically getting E002 ("Low pressure on heating side" per manual) and E011 ("High pressure on heating side") errors, on same day.
Sometimes turning machine on and off resolves it, or they go away on their own. Over the last month it has become more frequent. The PSI reading on the gauge above the expansion tank is fairly consistent around 15 PSI. The display on the Navien flashes P58 during the E011 error and between 5 and 6 during the E002 error.

Any ideas or anything I can do? I've been reading that it may be a defective pressure sensor and am thinking about replacing the pressure sensor. Ive included images of the set-up.




The machine has been descaled every year. Thank you for any help

Comments

  • Ironman
    Ironman Member Posts: 7,379
    edited November 2017
    Options
    If the pressure gauge is accurate, then it's a good the chance the sensor is malfunctioning. I'd remove it and see if it's plugged. If it is, you need to check for system leaks which would cause fresh water, minerals and oxygen to be constantly added.

    I believe there's also a strainer below the pump that needs to be checked:



    When you say "descaled", I assume you mean on the potable water side?
    Bob Boan
    You can choose to do what you want, but you cannot choose the consequences.
  • EraGem
    EraGem Member Posts: 2
    Options
    Thank you, Bob. Will check the sensor and strainer. Really hoping it's not a leak somewhere.

    Yes, descaled on the domestic water side.