Click here to Find a Contractor in your area.
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

HELP! Rinnai RC98ip

AKguyAKguy Member Posts: 5
Hi,
I have a 2 year old Rinnai 98ip tankless water heater that is throwing the error code 11. My gas pressures have all been checked, I have gas on hand, the piping size etc... is correct. I first started getting a code 12 only when I tried to fill the tub, but a single shower or faucet would work just fine. Now, I get a code 11 with no ignition at all. However, if I isolate the gas supply valve, turn on the sink and open the gas valve at just the right time during it's sequence it will fire up on low fire and then error out within 10 seconds or so as a code 12. I have checked the venting and no obstructions. I put a screwdriver next to the gas solenoid valve and when it calls for gas there is definately magnetism there so the valve has power....I'm lost and unfortunately live in the middle of nowhere Alaska so my resources are, well, none. If anyone can help me troubleshoot this issue, I would be very grateful!!!!
Thank you in advance,
Christopher

Comments

  • dlebnikoffdlebnikoff Member Posts: 6
    To me it sounds like you may have a problem with the gas supply. Like you said at first you had a problem when just filling the tub. That tells me when you use a lot of hot water the heater needs a large volume of gas all at once and you did not have it. Also like you said if you shutoff the gas valve and opened the valve at the time of ignition it would start and then shutoff. That tells me you that when the valve is closed you are building up the gas pressure and then when are opening it you get a lot of gas at once but then you cannot maintain that pressure. From what i have read i don't think its anything to do with the gas valve or lighting sequence but it will light. So that tells me the equipment is working. For two years everything has been working fine correct? So to me it sounds like everything was installed correctly. So if the fresh air and the exhaust and working correctly and both are not blocked or partially blocked. I have worked on a lot of Rinnai products and it is usually not the parts that go bad it is other things. I like to say with these products you have to crawl before you walk. You have to take one step a time. What was the gas pressure any way? Have you checked to see if the propane tank is low on fuel?
  • AKguyAKguy Member Posts: 5
    Thank you for getting back so quickly! I had a gas company come out yesterday, that was a long expensive trip for them, to supply me with 200 gallons of propane in new tanks, new regulator, etc. I'd have to look at the sheet again but the gas pressure was like 11.5" W.C. I believe. On the air intake and exhaust, I only looked at the vent to verify it wasn't blocked. It seems pretty simple to pull the fan out to inspect the squirrel cage in the fan??? I wonder if over the last 2 years I haven't built up bugs and crap and it's just now finally choked off? Any thoughts on this? Then I considered shutting off the gas, pulling the ignitor and starting the unit to check for spark??? I don't have any parts or gaskets so I'm hesitant on getting too far into removing things...Thank you in advance!
  • Leon82Leon82 Member Posts: 448
    That ignitor and flame sensor should be cleaned yearly. I use the grey scotchbrite
  • AKguyAKguy Member Posts: 5
    Leon82,
    Thank you. To clean those, do I just unscrew the little cover holding what I believe to be the ignitor, flame sensor and maybe a thermistor right next to the observation port on the front of the burner assembly?
  • Leon82Leon82 Member Posts: 448
    I believe so. I have a different brand. But it's usually one or two screws
  • dlebnikoffdlebnikoff Member Posts: 6
    To access the flame sensor and the ignitor its either 2 or 3 screws right next to the observation port. I would try what Leon says as the next step. To disassemble the vent fans on most of these units is a nightmare.
  • AKguyAKguy Member Posts: 5
    Update,
    So last night after work I removed the fan, it was 100% clean.
    I removed and cleaned, even though neither was caked with anything, the ignitor and flame sensor.
    I valved the propane out, pulled the ignitor, turned the unit on and the ignitor had spark.
    Put it all back together and it fired right up. After a couple of minutes I turned on my cookstove and the hotwater heater threw an error code 12. After that, I couldn't get it to relight without closing the gas isolation valve and slowly opening during the ignition sequence.
    I'm at a complete loss. Can anyone give me a suggestion???
    Thanks!
  • rick in Alaskarick in Alaska Member Posts: 633
    I would put a gauge on the gas line and see if the pressure holds when it is trying to light. If it stays stable, then put it on the manifold and see what it is doing. This would at least tell you if it is a pressure problem.
    Rick
  • AKguyAKguy Member Posts: 5
    Thank you all for the suggestions. I will put a manometer to it tonight and post my results tomorrow.
  • lchmblchmb Member Posts: 2,562
    could be a grounding issue and or bad wire from the ignitor/sensor..
  • Leon82Leon82 Member Posts: 448
    Check the drain condesent drain for a blockage or vacuum lock
  • NorthernGirlNorthernGirl Member Posts: 12
    Christopher, did you resolve the problem? I too live in rural Alaska and have a code 12 problem on my Rinnai tankless that seems to be related to insufficient propane pressure. I have a similar problem with the tub faucet tripping the code 12 but the shower doesn't. Just wondered if you discovered anything new.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!