Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Steam radiator spud has lip that retains water - causing vent to close early?

I have a one-pipe steam radiator that never quite heats up. Soon after steam makes its way to the radiator, the vent gets wet and closes. If I remove the vent the radiator heats as it should. If I blow out the water and replace it, or swap it out with a dry one, it vents air for a few minutes until it gets wet again and closes. The vent is a Heat-Timer Varivalve quick vent, though I've swapped it out with other vents without success. Adjusting the vent rate in either direction doesn't help, either. The problem only occurs with one other radiator, on a different main, but even then it only happens once or twice a year.

When I took the radiator off to inspect it and flush out any gunk I noticed a pool of standing water at the bottom. It was held back from draining due to an inward lip on the spud, and I had to tip the radiator up nearly 30 degrees before the one-third cup of water or so would drain from it. See picture:



Is the standing water in the radiator likely causing the vents to get wet and close, or otherwise problematic? If so, can I just file off the lip on the spud? It looks like there is enough material to maintain a proper seal with the valve after I file a bit off.

Comments

  • EBEBRATT-EdEBEBRATT-Ed Posts: 5,853Member
    Looks like a burr inside. Yes, file it down reconnect and make sure the radiator has enough pitch.

    If problems continue, check the pitch and size of the piping.

    What pressure are you running??
  • CaptSkinnyCaptSkinny Posts: 4Member
    Thanks - I've filed off the burr and reinstalled the radiator. We'll see what happens in the morning.

    It looks like the pressuretrol is set to cut in at about 1 psi, with a differential of 1 psi. I'm not sure the gauge is working properly -- it bottoms out around 2.8 psi when the boiler is cold and reaches 5.6 once it heats up (the range is 1-30 psi, with 1.6 psi marking increments (8 marks per 5 psi).
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!