Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Tekmar 654

John JrJohn Jr Member Posts: 210
Has anyone use this control without problems? I have six in use and 4 of them I am having issues with. All have 090 sensors. The ones with issues the control turns the system on when the sensor is dry with no snow. I used to use the 664 with no problems at all and switch to using the 654 this year.

Comments

  • Paul S_3Paul S_3 Member Posts: 1,257
    edited February 2017
    @John Jr .... I've never had problems with this control....I have about 4 out there (2) with 090 snow ice sensors.....and another 2 with aerial sensors and slab sensors.... I would call there tech support which is really good in my opinion and there's a 8 part video on YouTube on this control. Where are you located? There are specific suppliers that deal with Tekmar and have really good support. For example by me in NYC it's Rathe associates in long Island and Thermco reps in jersey....maybe your settings are off..... "idle mode"?.....residentially I use a user switch and the customer can press a "storm" button to get the slab ready for a storm on its way.
    Paul S
    ASM Mechanical Company
    Located in Staten Island NY
    Servicing all 5 boroughs of NYC.
    347-692-4777
    [email protected]
    ASMHVACNYC.COM
    https://heatinghelp.com/find-a-contractor/detail/asm-mechanical-company
  • ZmanZman Member Posts: 6,029
    I have been having that same problem intermittently with a pretty big system. The local rep has been blowing me off. I think I now know why.
    I will call them gain Monday and keep you posted.
    "If you can't explain it simply, you don't understand it well enough"
    Albert Einstein
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!