Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Honeywell S8610U Showing Damper Error With No Damper In System

After two years of flawless use my Honeywell S8610U Universal Control has stopped lighting my Kenmore boiler. It's showing Error Code 5 - Damper Error. My system doesn't have a damper. The whole thing worked fine for two years. Why the sudden damper failure? Has the control unit just gone bad?

Comments

  • AbracadabraAbracadabra Posts: 1,948Member
    If it never had a damper installed or there's no damper jumper on the control, the control may be bad.
  • Tim McElwainTim McElwain Posts: 4,281Member
    Is the S8610U a grey box or black? If it is a gray does it have a jumper in place on the control? If it does shut the power off, remove the jumper, then put the jumper back and power up the unit. The S8610U is a Universal replacement which replaced the original module.

    I think however you may have the S8610U-3009 a black plastic module if so there should be no jumper in place on the module. Try removing the 24 volt connection and then with power off reconnect and then power up. If it does not recover call for a professional but your module is probably gone and needs replaced.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!