Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Troubleshoot GVD-6 problem

gazzerp
gazzerp Member Posts: 14
New steam system installed Aug '12: Utica PEG150; FieldControls GVD-6 Vent Damper; M&M PS802 Low Water Cutoff; M&M MM323 Electronic Water Feeder; Honeywell PA404A Pressure Control; Taco SR501 1-zone Switching Relay; SuperStore SSU-45 Indirect Water Heater.



Boiler failed to ignite at some point yesterday.

 

Began troubleshooting with vent damper - vent closed, room thermostat and/or SuperStore calling for heat and service switch in (normal) Automatic position:

- Have power (26v) between 4&1 and 4&2 (BLK/BRN and BLK/ORG)

- Motor does not function



Repeated above, this time with switch in (override) Manual position:

- Have power (26v) between 4&1, 4&2 and 4&3 (BLK/YLW)

- Motor functions (vent opens)

- Boiler ignites



I disassembled the unit and saw some minor discoloration around the brown diode/resistor on the circuit board.



Given the above, could the problem be anything other than the damper?



Thanks in advance,

Gary

Comments

  • Tim McElwain
    Tim McElwain Member Posts: 4,477
    The relay

    wired between 4 and 2 is defective. When you go to override (manual) also called hold open the system will work as you are bypassing the relay. When in manual you have a direct feed to the motor which will cause the damper to open and close the two end switches and bring on the equipment.



    The diagram in the books is not very good. I have a internal diagram of the damper which I can fax you or e-mail contact me at [email protected]