Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Burnham Revolution RV4NSL-L2 no ignition

Vit Member Posts: 3

I have Burnham Revolution RV4nsl-l2 boiler installed around 2000. About a week ago I have installed 2 programmable thermostats LuxPro instead of old Honeywell dial-style ones.

Shortly after the installation I've noticed that sometimes the heat doesn't turn on as programmed, and after visual inspection I've noticed that there was no pilot light, and even though thermostats were working properly, the water in pipes was cold. I turned the boiler off and then back on, and the light lit and the water started heating up, so it was my fix for a few days.

This morning restarting the boiler didn't make the pilot light appear, so currently my heating system is not working at all. I've tried restarting it a few times, I can hear the sound of water being pumped through the pipes, but the water is not heated, as there is no pilot light and burners are off.

Honeywell SV9502 controls the gas and ignition, I tried switching gas control on and off without any luck.

Please let me know what can be done in this situation.

Thank you in advance.


  • Tim McElwain
    Tim McElwain Member Posts: 4,588
    That boiler uses

    Honeywell Smart Valve for an ignition system. Does the boiler have an L8148E relay? If so when the thermostat calls do you have 24 volts at B! and B2 on the relay?

    Do you have circulators or do you have two zone valves and an single circulator? If zone valves what make and number are they?
  • Vit
    Vit Member Posts: 3

    I called an electrician I know, he came over and took a look. He checked all voltages, and there was nothing wrong with it. He was able to get the proper ignition sequence going, but the problem was that it send turn off gas signal 15-30 seconds after the start. He jumped cables from the blower control, and the gas stopped turning off all the time, then he removed the piece of wire he used to jump cables and the thing just kept working.

    Other findings:

    It appears that my furnace had some water damage, and the pump that forces the hot water to the base boards don't work, so the water goes through the circuit very slowly.

    I am still not 100% sure what is wrong with it, I'll post the update shortly.
  • Vit
    Vit Member Posts: 3
    edited December 2013

    Yes, there is a relay L8148e. There are 2 zones with regulators.
  • Tim McElwain
    Tim McElwain Member Posts: 4,588
    Place your meter on

    terminal B2 on the L8148 Relay. Place the other lead on B2, when there is a call for heat do you have 24 volts? Is the combustion air blower running?

    When the CAB comes on it should cause the SPDT pressure switch to make N.O. and send 24 volts to the SmartValve. Is this happening when it will not run?

    If it is not coming on every time you will need to check with a digital manometer across the pressure switch hoses. If you have the manual for the boiler the procedure for  that is found on page 76 in the manual.
This discussion has been closed.