Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

UTICA DV-100 PROPANE PROBLEM

lagacylagacy Posts: 1Member
HI,

I HAVE A UTICA PROPANE GAS HOT WATER  BOILER ABOUT 15 YEARS OLD. WITH THE THERMOSTAT CALLING FOR HEAT THE DIRECT VENT BLOWER COMES ON AND THE ELECTRONIC PILOT LIGHTS BUT THE BURNERS DON,T LIGHT. ALSO LATELY EVERY SO OFTEN THE BOILER WOULD MAKE A LOUD ROARING SOUND AND THE BURNER TUBES WOULD BE FILLED WITH A FLAME. COULD THIS BE A BAD GAS VALVE OR THE S8600M CONTROL. THANKS FOR ANY HELP.

Comments

  • Tim McElwainTim McElwain Posts: 4,279Member
    You have two things happening

    that may or may not be directly related. If the pilot is lighting and the main burners are not then you have a flame rectification problem. Someone who knows how to do this should be contacted and they need to measure the microamp output from the system. It may be a very simple solution of just cleaning the flame rod and that problem would be solved.



    The second issue of flashback into the burners is a combustion issue which may be solved by cleaning the burners and adjusting the air to the burners.



    This type of work should be done by a professional.
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!