Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Old York High Efficiency Problem

Yorkman
Yorkman Member Posts: 3
Greetings:

This seems like a great website - glad I found it.  This is my first post.  I have a problem with a 20 year old York gas furnace.

The problem is the second stage blower starts right away (like normal) but no igniter, no main blower and no heat.  The condensate trap (which I've had problems with) was full of black particles (hydrogen sulfide from the well water probably) and there was water on the floor of the unit.  I cleaned the trap and blew it out with compressed air - seems very clear now.  I primed it with a little water in both of the inlet ports and reinstalled. Still no heat.

In the past this unit has had problems with loose/intermittent electrical connections - I reseated all connections.  This unit had a new control module and igniter within the last 2 years.

Question

1) Any thoughts on what could be the problem or what I can check to further troubleshoot ?

2) I tried the furnace without the trap connected - still didnt work.  Will a furnace run without a trap ?

3) Can a trap "go bad" even if it seems clear ?

thank you much for any assistance/help

regards, steve

Comments

  • Tim McElwain
    Tim McElwain Member Posts: 4,552
    I assume by

    your reference to "second stage blower" you are refering to the combustion air blower???



    If the combustion air blower is running then the 24 volts and 120 volts to the furnace are fine. Your problem is probably that the pressure switch is not making when that blower comes on. The switch typically has a SPDT switch with the switch  making common to Normally closed with no call for heat. It should then make common to normally open when the combustion air blower is on.



    You can temporarily jump out COM to NO with the blower running. If the furnace then fires replace the pressure switch. This assumes there is no blockage in the hoses to the switch.



    I do however recommend getting a professional to look at it.
  • Yorkman
    Yorkman Member Posts: 3
    York problems - new information

    Thanks TIm.

    I did some more troubleshooting and found that the voltages coming off of the transformer might not be right.  I have an identical unit for the first floor so i can compare the voltages.  The transformer has 5 outputs - 2 are supposed to read 24-28 VAC and the rest are about 8 VAC (based on measurements of the "good" unit).  On the bad unit, I have the 2 @ 24 VAC but the other three (going To the thermostat) are about 0 VAC.  So I'm thinking it's the transformer.  If that conclusion is correct, I don't know if it took out the relatively new White Rodger Control Module (it has an LED that's always supposed to be lit but it's not).  DO you have any thoughts given this new information ?  THank you.

    If the transformer is the problem, can I buy one on this website (new to the site so I don't know).

    best regards, steve
  • Tim McElwain
    Tim McElwain Member Posts: 4,552
    I think you have a furnace control center

    which includes a transformer and relay, if that is the case then "R" and "C" should be 24 volts, that is the secondary of the transformer. The other contacts are "W" for the heating system and "Y" and "G" are for cooling and are just tie in points for wires.



    It would help if you could get a make and model of the White Rodgers control module, that way I can check the diagnostic info on the control.



    We do not sell parts here but you can usually find a Plumbing and Heating supply near you or call a professional service company to come and they will be able to get you any controls you need.
  • Yorkman
    Yorkman Member Posts: 3
    Found the problem

    Hello

    The problem turned out to be a fusible link on the top of the combustion/burner section.  This is wired in series between the pressure switch, the limit switch and the final destination - the control module.

    I'm wondering if it just failed after 20 years or there might be an overtemp problem with the heat exchangers ?

    Thank you for your help Tim.

    regards, steve
  • Tim McElwain
    Tim McElwain Member Posts: 4,552
    That sounds like the flame

    rollout switch. If this is the first time it has failed in 20 years then it could just be that it finally got old and failed or



    if it is doing its job it means that there may be a combustion problem in the chamber which should have a professional take a look at it. They should also do a combustion test to make sure it is firing safely and efficiently.
  • Empire_2
    Empire_2 Member Posts: 2,343
    edited November 2009
    Hate to barge in,....Sorry

    With all the dialog I read. The symptoms you described were pointing to an open safety, (your fusible link).  I'd be willing to bet either you primary or secondary heat exchanger is cracked......  I'll bet a brick in the wall!  I f you disconnect any safety control you can observe the identical scenario you described.  Check it out.



    Mike T.  My .02
  • Tim McElwain
    Tim McElwain Member Posts: 4,552
    This is why I

    recommend getting a professional to come look at your furnace, as Mike T points out it could very well be a cracked or damaged heat exchanger. This will require replacing the furnace. Do not however hesitate as this can be dangerous.



    Do you have a Carbon Monoxide detector in the dwelling? if not you should have one.
This discussion has been closed.