Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Rinnai tankless - intermittent hot water and no error code

I have a Rinnai tankless RC80HPi water heater. It was installed in my house back in 2009. It has been working flawlessly up until about 2 weeks ago. Then all of a sudden while trying to run hot water in either of the showers or in the kitchen sink, the hot water would start cycling between cold and hot. This cycling happens randomly and for various amounts of time. Sometime the cold water will last for 30 second, sometime it will last for a minute.
With the hot water at the kitchen sink and/or the shower turned on - if I am standing in front of my Rinnai water heater, I can see the water heater turn off and the In Use light go out. Meanwhile I can still hear water running through the water heater. The heat is just off. Then about 30 seconds to a minute later, the Rinnai water heater will fire up and start producing hot water again.
There are no error codes. The display consistently and always displays "120". I've checked to see what the water flow is through the water heater, it is 26 when I have the shower on and 11 when I have the sink on. I've checked to see what the outlet water temperature is, it is between 108 and 110 always.
I regularly flush this water heater, thus it is generally well maintained.
Twice in the past 3 days I have opened up the Condensate trap drain plug, and maybe a cup or two of water has flushed out. Is that normal?
Does anybody have any advice on what I can check next or what may be going on? I am at my wits end with this and want to get back to having an endless supply of hot water during showers or while doing dishes!

Comments

  • DZoro
    DZoro Member Posts: 1,048
    When you flush the water side are you using a cleaner?
    Has the burner side been maintained annually?
    There should always be some condensate inside the trap. When the system is running is there a steady flow of condensate running out?
    lukekr12
  • lchmb
    lchmb Member Posts: 2,997
    go into the control and check your gpm. I'd start guessing your flow servo is failing..
    lukekr12
  • lukekr12
    lukekr12 Member Posts: 3
    Thanks DZoro!
    I didn't realize there was a "water side" and a "burner side". When I flush my tankless water heater annually I "flush the heat exchanger" with a solution of white vinegar and water as described in the Operation and Installation Manual.
  • lukekr12
    lukekr12 Member Posts: 3
    Thanks Ichmb!
    When you say "check your gpm"...is that done by pressing the up arrow for 2 seconds and then pressing the "On/Off" button? Or is there a different way to check gpm?
    I've done the way I described...and with the shower on the digital display shows 26; with the kitchen sink on it shows 11. I'm guessing that is gpm...
  • Intplm.
    Intplm. Member Posts: 1,384
    Might be that the fan and or the exhaust is dirty. Also, I'm not sure, but the gpm has to be just around 3 gallons per minute. (That's water flow rate feeding the unit.) If it fluxuates lower, the unit will tend to "hunt" for a reason to stay on which I think is what you are describing. If it stays on longer, you might find that it will show an error code and then shut down.
    So. Try checking the fan and the fan housing for dust build up.Check if water use has changed possibly reducing the water flow to the heater.
  • RBDeRoo
    RBDeRoo Member Posts: 1
    LukeKR12 - did you figure this out? I have the same problem
  • psb75
    psb75 Member Posts: 571
    Make sure your faucet aerators and shower heads are clean and free of debris that may be restricting flow.
  • HVACNUT
    HVACNUT Member Posts: 4,620
    > @RBDeRoo said:
    > LukeKR12 - did you figure this out? I have the same problem

    Are you sure there's no code?
    I had a Rheem tankless last Thursday. The client reset it so it was ROA running on arrival. He said there was no code, just displayed a temp of 79°. I called tech support and 79 is a code not in the Customer Care Manual. This code was a blower motor fault. And of course they recommend replacing the board as well.
    I don't come across too many tankless water heaters. This one was for a pool house so no emergency. He's gonna wait until it's dead dead.
  • Intplm.
    Intplm. Member Posts: 1,384
    Is the gas main of adequate size?? It will shut down if the gas isn't flowing as needed.
  • jonl123
    jonl123 Member Posts: 3
    edited September 2020
    I assume you got to the bottom of the issue?

    Same exact problem here. No code. Tried flushing the unit but that didn’t help.

    Unit makes a loud rumble (very loud) when it kicks on. This was the only issue for maybe a week or so. Today it started kicking on/off while calling for hot water. So the water cycles hot/cold/hot/cold...

    Flow when kitchen sink is on is 10-11 (I assume gpm, but logically it's not moving that much water of course, so maybe it's liters?... It’s the number you see when pressing up and power on the controller). 

    We’ve had a lot of things done recently that could have caused something to go wrong: roof replaced, water treatment system installed, flow turbine in hot water heater replaced, condensate neutralizer installed (this is over a 2-4 week span).
  • jonl123
    jonl123 Member Posts: 3
    Wanted to update that I checked the exhaust pipe up on the roof and it all looked fine and clean. Tested today and off one of the bathroom sinks it ran perfectly for 10-15 minutes. Turned it off, turned on kitchen sink and the problem started happening again. It happens with other faucets too.

    Watching the unit, during those 10-15 minutes, I didn't see any condensate dripping out, so I'm wondering if something is going wrong there.
  • AggieOilman
    AggieOilman Member Posts: 1
    Did anyone find a solution to this issue? Dealing with the exact same and have a repairman coming.
  • BradSmith
    BradSmith Member Posts: 1
    My Rinnai tankless water heater exhibits this sort of behavior. Cleaning the squirrel cage exhaust fan of bugs, which causes an imbalance slowing airflow, remediates this intermediate hot water flow behavior.

    Tutorial video demonstrates the issue and resolution to restoring regular hot water.
  • rick in Alaska
    rick in Alaska Member Posts: 1,378
    If your water heater is showing 108 degrees output while it is running, and you are not getting hot water at the fixture, then you have a cross connection somewhere. You should still be getting 120 degrees however, so you might be dealing with more than one issue. But first, check your plumbing and see if there is a place where the hot water can get back in to the cold water.
    Rick
  • jonl123
    jonl123 Member Posts: 3
    BradSmith said:
    My Rinnai tankless water heater exhibits this sort of behavior. Cleaning the squirrel cage exhaust fan of bugs, which causes an imbalance slowing airflow, remediates this intermediate hot water flow behavior. Tutorial video demonstrates the issue and resolution to restoring regular hot water.
    I had high hopes for this fix, but unfortunately it didn’t do the trick for me. 
  • jcormier
    jcormier Member Posts: 1
    Did you ever get this resolved? I'm having a similar issue with my RU98i. No error codes and it runs for several minutes but when demand gets too high it shuts down. It's almost like it's experiencing a flame failure due to not enough gas. I wonder if the burner assembly needs cleaning or if one of the gas valves are not opening. Note: The fan has little to no vibration and appears to be working very well. I took it off to verify how clean it was an all was good.
  • wasillaguy
    wasillaguy Member Posts: 1
    edited April 10
    I have the same issue with my Utica-Dunkirk
  • mattmia2
    mattmia2 Member Posts: 5,700
    Are you checking the gas supply pressure under load when it happens?