Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Old furnace

quickfixer33quickfixer33 Member Posts: 2
So I'm nothing special, but I'm pretty handy and can fix most things. With that being said had a leak in my outside above ground oil tank from the filter housing. The furnace still worked, all of a sudden when I buy a new filter and housing the furnace stops working just makes a humming sound. So I switch the filter housing and the shut off valve from tank to filter just spins and then just pulls off, I put vice grips under the release nut, and I prime the furnace, the bleeder is sucking air in so I put a clear tube on it and use a syringe and try to pull the air out it just keeps sucking air and won't let a flow come through should I replace the pump. I'm not rich and times are tough what's my best option???

Comments

  • STEVEusaPASTEVEusaPA Member Posts: 3,949
    Sounds like one or a combination of things. I'm assuming a one pipe system.
    Is the filter outside? Should be moved to the inside.
    What type of shut off valve? It may not be fully open, may have failed shut, or you may have a restriction in the line.
    If you put a clear tube on the bleeder, put the other end of the tube in a can submerged in about an inch of oil, and it sucks that oil up into the pump, you have a restriction. You'll especially see it after the burner shuts off. If that is happening, I'd say, without confirming with a vacuum gauge, the pump is probably ok, unless you tried bleeding a dry pump with a restriction for a long time.
    Don't know what type of filter/filter housing and shut off valve you have. Post a picture.
    Is the burner (motor) not running at all? Don't know what is humming.

    Of course your best option is to have a qualified competent tech come out and diagnose fix the problem. Might be cheaper in the long run, especially if you have a restriction, burn out your pump, buy a new pump, burn that out, then start throwing other parts at it.
    steve
  • EBEBRATT-EdEBEBRATT-Ed Member Posts: 6,709
    Sounds like your valve at the tank is shut off. If it's a firomatic it is spring loaded shut
  • quickfixer33quickfixer33 Member Posts: 2
    I'm pretty sure it's the shut off valve spring, I'm gonna change the valve for now it's just a quick fix I have a stand up tank and regulations call for lay down tank which I'm switching to. I was really hoping it was the pump...
  • EdTheHeaterManEdTheHeaterMan Member Posts: 398
    edited January 14
    If you have a full tank or half-full tank and you want to remove a plug or valve from the bottom. put a shop vac on the tank vent and turn it on. the vacuum will keep the oil from leaking out the bottom while you change the valve. This must be done carefully. too much vacuum can collapse the tank and then you will be in a real pickle.

    If you have a Firomatic valve... you may just need a new valve handle.

    Here is a picture of a fully open valve


    here is a pic of a partially closed or completely closed valve


    Get that stem UP! the oil will flow.


  • EdTheHeaterManEdTheHeaterMan Member Posts: 398
    The humming sound is because it forgot the words! :p

    ...or the pump is stuck and you just need to spin the squirrel cage to get it moving again. Is this a one-pipe from the tank or a two-pipe from the tank?
  • EBEBRATT-EdEBEBRATT-Ed Member Posts: 6,709
    Or it could be humming because the valve is close or partially close causing a restriction.

    If the valve is bad and you can't change it you could plug it off and put the oil line into the top of the tank
  • EdTheHeaterManEdTheHeaterMan Member Posts: 398
    I'm thinking the hum means the burner motor is stuck and not moving. The hum of a stuck motor or the buzz of the ignition. If the valve on the supply and return are both closed the pump is hydraulic locked and the starting torque of the motor can't overcome the hydraulic lock of the gearset on the pump. If it does eventually start and run with both valves closed, POP goes the pump seal.

    That is why you never put a valve on the return line of a fuel system. But that assumes facts not in evidence (as Perry Mason might say) Oh gosh i'm old!
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!