Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Troubleshooting Argo AR822 switching relay

My equipment is approaching 20 years old: a Buderus G124 propane boiler, off which I have three Argo relay switching units. A primary (probably an AR861-3; I'm away from my house at this time... which contols two HWBB zones and an indirect HW tank [with priority switch]) plus, two AR822 units - one for another HWBB zone (bedrooms) and the other for numerous radiant zones (with additional switching/controls, of course.)

The bedroom zone is malfunctioning. The call for heat is registered (green LED illuminates) but, the relay doesn't operate. The radiant zone is working correctly.

First thought was the relay is dead.

But, I swapped the relays between the bedroom unit and the radiant unit to verify. The bedroom relay, in the radiant unit, does not close. So, to me, that at least confirms the relay is dead.

Next step was to use the good relay from the radiant unit, in the bedroom unit: the relay doesn't close and the zone still fails to open.

I note from the reference material that the AR822 has an "Auto-Reset Electronic Fuse Protection" feature. I assume that, had there been some form of electrical "blip" that this would have "reset" itself?

That being the case, would I be safe in assuming that the entire unit has failed or, are there additional troubleshooting steps that should be undertaken to prove this?

Once again, note that I am currently away from the subject property so, if additional eyes/hands-on activities might be required, they'll have to wait until I'm next on-site.

If, however, through reaching out here for advice determines that my current unit is without doubt dead, I'll have sufficient time between now and when I'll next be at the property to order/receive a replacement.


Thank you.

Comments

  • STEVEusaPA
    STEVEusaPA Member Posts: 5,315
    edited November 2017
    Although it looks complicated, it's basic troubleshooting that needs to be done with a meter.
    With no power applied, confirm N.O & N.C contacts
    Confirm power coming in, qualify & quantify.
    Confirm t-t is closing.
    Confirm power is going to the zone valve/or circulator.
    If you know how to work a meter, here's the instructions
    http://us.argoindustries.com/sites/default/files/1546_0.pdf
    steve
  • gazzerp
    gazzerp Member Posts: 14
    Steve, thanks for responding. I do have a meter but, as noted, I'm not at my house at present.

    The ARGO instructions indicate:

    1. When the thermostat connection to TR/TW calls for heat the
    “circuit ON” LED is illuminated.
    2. The relay will then close.

    So, I see the first step happen. As soon as I flip the dip switch to call for heat (I have an Echelon home control system) for the bedroom zone, the LED illuminates.

    But, the relay does not close. No click.

    As I'd noted earlier, swapping the relay between the (failing) bedroom AR822 and its neighbor (the radiant zone, which is working just fine) results in:
    a) The bedroom zone still does not close; and
    b) Now, the radiant zone also does not close.

    To me at least, this indicates that the bedroom relay is dead.

    But that doesn't explain why the good (radiant zone) relay won't close when it is installed in the malfunctioning, bedroom AR822.

    The literature for the unit notes the presence of an "Auto-Reset Electronic Fuse Protection" feature. Not being at my house I can't look to see if this is a button/pin that needs to be pressed to "Auto-Reset." If that's the case, I'd say there's not much "Auto" involved in that feature... Can you tell me how this actually works?

    If there is a button/pin to press to reset the unit, then kindly ignore the balance of this post. I shall be at my house a week from now and can continue troubleshooting at that time.

    However, assuming that the feature is truly automatic, I assume that whatever it's supposed to protect, has been/remains protected.

    And that with T-T closed, the LED illuminated and a good relay in place, is there anything else that could prevent the relay from closing (and the remaining two, sequence of operation steps) from taking place?

    3. The contacts between 3/4 NO and 5/6 NO will close.
    4. The contacts between 3/4 NC and 5/6 NC will open.

    If not, can it be unequivocally determined -- based on the described/observed behavior -- that the unit has terminally failed?

    Thanks
  • STEVEusaPA
    STEVEusaPA Member Posts: 5,315
    Looking at my attachment, which diagram looks the most like yours?
    Also, what happens if you remove the thermostat wires from t-t, and put a jumper across them?
    steve
  • gazzerp
    gazzerp Member Posts: 14
    Page 7: AR822-II CONTROL BOARD

    The LED is normally off and illuminates only when the bedroom calls for heat (naturally or, if I manually cause it to do so.)

    I'm happy to do as you suggest but, it won't be until next Thursday when I'm back at my house.
  • EBEBRATT-Ed
    EBEBRATT-Ed Member Posts: 10,311
    The only thing I can think of is loose or defective thermostat wires or thermostat. The LED light could be on dimly possibly high resistance will light the led but not allow the relay to pull in.

    Remove the thermostat wires and try the jumper that @STEVEusaPA mentioned
  • Paul48
    Paul48 Member Posts: 4,470
    Along the same lines.....How about low transformer secondary voltage?
  • gazzerp
    gazzerp Member Posts: 14
    Arrived at my house last night and just jumped the T-T connection on the unit. Relay did not kick-in...

    Just to cover all bases, I once again swapped out the relay with the one installed in its neighbor (whose zone is functioning as expected.)

    It worked; the relay clicked and the circulation pump started.

    Baffled, I reattached the T-T wires and manually caused that zone to close. Relay again clicked and zone started.

    I'd apologize for wasting people's time but, I swear I swapped out the relays before I initially reached out for help. The only "difference" came this time in jumping the two T-T connections. If this might have caused it to "wake up" - who knows?

    My thanks to those who offered input.



  • HVACNUT
    HVACNUT Member Posts: 4,196
    It's possible the cube relay is on its way out. Pick one up as a spare just in case.
  • EBEBRATT-Ed
    EBEBRATT-Ed Member Posts: 10,311
    @gazzerp , the only important thing is you fixed it (apparently).

    Low voltage problems are in some ways worse than line voltage 120 volt problems. Small wire breaks more easily, lower voltage is more easily stopped by high resistance, dirt, rust, loose connections and sometimes sloppy workmanship because "it's just low voltage"