Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Peerless boiler smart valve igniter

britrlit11
britrlit11 Member Posts: 3
edited January 16 in Gas Heating
Ignitor will not come on.
On a peerless boiler hydronic baseboard system, smart valve sv9501m2700. I am getting 28 volts on the wire plug that fits into the gas valve between red and black wire.  
When I insert this 4 prong plug into the gas valve,  I read 28 volts between the 2 pins where the wire plug for the igniter fits onto the gas valve. This would be 28 volts for the 2 blue wire that go to the igniter. 
I am reading 5 ohms on the 2 blue wires on the igniter. It is a new igniter assembly. Pilot, igniter,  and flame sensor. 
Any suggestions,  help would be greatly appreciated.  
Thanks 

Comments

  • EdTheHeaterMan
    EdTheHeaterMan Member Posts: 7,499
    edited January 16
    Your description sounds like it is the way it is supposed to be. The blue wires should show some resistance because the Hot Surface Igniter is an electric resistance heater glow stick. That electric current traveling thru the resistance makes it get hot.

    The 28 volts is within range of the gas valve operation. So that is good. But I'm guessing that you did not post that just to say that everything is just fine. I will bet you are having a problem. Can you describe your problem?
    Edward F Young. Retired HVAC ContractorSpecialized in Residential Oil Burner and Hydronics
  • britrlit11
    britrlit11 Member Posts: 3
    Yes. The igniter will not come on
     It will.not glow like it supposed to. I
    Thanks

  • britrlit11
    britrlit11 Member Posts: 3
    edited January 16
    Ok,  I found the problem.  When the wire plug for the igniter was plugged in, I could not read 28 volts on the top side of the plug for the 2 blue wires. Took the plug off and now I cannot read 28 volts on the 2 pins on the gas valve where the 2 blue wires fit.  I kept probing with my meter leads on the 2 pins where 2 blue wires on the gas valve and reading 28 volts again. One of those 2 pins on the gas valve is not making a good connection. I am going to see if i can maybe resolder it.I  am going to take it apart and see if I can get it fixed. I will keep you posted