Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

TACO SR501 red light not turning on at all (2 zones)

Options
apervizi
apervizi Member Posts: 2
Hi there,

The red light on the TACO SR501 is not turning on at all (2 zones).

There is power to the TACO SR501

Up to now it has worked fine.

Both thermostats are calling for heat and the gas furnace system is not turn in on (pilot is on).

Any help would be appreciated.

Thanks

Comments

  • Alan (California Radiant) Forbes
    Options
    The red light on the TACO SR501 is not turning on at all (2 zones).
    The Taco SR501 will only power 1 zone, i.e. 1 pump.

    Is the green light on?

    If you jumper T-T and the red light does not come one, the relay is bad. Replace the control.
    8.33 lbs./gal. x 60 min./hr. x 20°ΔT = 10,000 BTU's/hour

    Two btu per sq ft for degree difference for a slab
    kcopp
  • Joe Mattiello
    Joe Mattiello Member Posts: 707
    Options
    Alan nice call to validate demand at TT terminals to rule out thermostat. 
    The green light should be illuminated too; validates SR has voltage to transformer.
    also did you change thermostat to power robbing type? 
    Try calling Taco tech support at 401-942-8000 for additional support.
    let me know how you make out
    Joe Mattiello
    N. E. Regional Manger, Commercial Products
    Taco Comfort Solutions
  • SteveSan
    SteveSan Member Posts: 235
    Options
    Are you trying to control two pumps with two t-stats? If so, you should be using our SR502-4. Please give us a call during normal business hours Mon-Fri 8am-5PM EST 401-942-8000
  • Guava
    Guava Member Posts: 1
    Options
    Is there supposed to be a jumper between T-T? A year ago I had to replace my generator after a power surge fried it. Been fine for the year but now I have a green light but no red light when furnace is on. 

    Furnace turns on/off but doesn’t seem to be following the thermostat. Have it set at 68 but tEMP is up to 73 and the furnace will still run. 

    I put a jumper on T-T and have a red light. 

  • dko
    dko Member Posts: 611
    edited March 2023
    Options
    Guava said:

    Is there supposed to be a jumper between T-T? A year ago I had to replace my generator after a power surge fried it. Been fine for the year but now I have a green light but no red light when furnace is on. 


    Furnace turns on/off but doesn’t seem to be following the thermostat. Have it set at 68 but tEMP is up to 73 and the furnace will still run. 

    I put a jumper on T-T and have a red light. 

    The jumper on TT is just to test if the thermostat is working. It is emulating the call for heat from the thermostat. It should not be there permanently, otherwise it would be calling for heat (firing your furnace) continuously until it trips off a safety.

    Remove the jumper and check your thermostat. Not sure what thermostat you have so it is difficult to provide more instructions, but generally.. if it has power and you have an off-heat-cool toggle check to make sure it's on heat.

    If not that.. change batteries/test with a new thermostat.

    If not that.. will require much more info. Equipment photos, control photos, as a means to see how everything is wired.
    EdTheHeaterMan