Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Carlin EZ-Gas 'No Flame Detected' on startup

maraakte
maraakte Member Posts: 1
Hello,

Recently we had a large basement flood from the hurricane and unfortunately sump pump float was stuck so we didn't notice it until the next day.  Basement was flooded about 2 to 3 feet.

The furnace is an oil converted to use carlin ez gas.  The controller board needed replaced as it was shorted.  I first took the blower motor out and cleaned out water with compressed air, ran the fan manually for 24 hours, opened the top cover to verify no water got into the ignition/flame area (with gas off!), I replaced the controller and the burner came on and was fine.  However the relay on the Honeywell l8124c aquastat was not opening the circ pump.  I shut the unit down.  Let it sit for a week until today and put the new aquastat in.

The new problem is as soon as I power on the unit and the controller starts up it immediately (as in 5 seconds after it shows the model/version info) is "no flame detected" and goes into lockout.

I made sure the wiring of the new aqustat is the same, even reversed the l1/l2 to check as the manual was saying if polarity is reversed coming to controller it can cause flame error conditions and no change.

This old burner may be wired up strange?  I am new to furnaces, but the tt goes to the tt pins on the aquastat.  It looks as if it was configured to have software shorted tt on the controller and the aquastat will cut power to the b1/b2 if heat is satisfied.  Is this normal?  I can provide pictures.

I'm unsure what to check next.  My guess is that there could be air in the system but considering it worked last week minus the relay issue I am doubtful.  But if the electric valve by the main goes bad could it cause this condition?  Is there a way to test the switch with a multimeter?  I wonder if the water submersion has finally killed this part as well.  I tried working it off/on a few times with power off and no change.

Thanks in advance, I'm sure a professional will be needed but it may just be a dumb easily missed mistake on my end!

Comments

  • Steamhead
    Steamhead Member Posts: 14,758
    2-3 feet of water? That entire unit must be replaced. FEMA and insurance carriers require this. Don't even try to fix it.
    All Steamed Up, Inc.
    Steam, Vapor & Hot-Water Heating Specialists
    Oil & Gas Burner Service
    Consulting