Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Embassy onex L04

pwm74pwm74 Member Posts: 5
Unit has been running great for the last 8 years. It randomly displays L04 code when It fires back up. I changed ignition electrodes and sensor electrodes. I also gave it its daily maintance. L04 stated to change control board. Is this a common thing after 8 years of use. Is there other chronic problems that cause code I could check before I call a tech or swap board. Thanks in advance

Comments

  • kcoppkcopp Member Posts: 3,608
    Thats the only resolution Embassy gives.
    The control board is not cheap.
    Hows the gas pressure? LP or Nat Gas
  • pwm74pwm74 Member Posts: 5
    I have natural gas.Did not check gas gas on unit, do not have a manometer. 
  • kcoppkcopp Member Posts: 3,608
    When was the last time the boiler was pulled apart and cleaned?
  • pwm74pwm74 Member Posts: 5
    It was cleaned early December. Followed the manual. Was pretty clean. I will test pressure this weekend with manometer.

  • pwm74pwm74 Member Posts: 5
    Running max
    Non running


  • kcoppkcopp Member Posts: 3,608
    Gas pressure looks decent. Any other things that may have been going on when this happened? Power fluctuations?
  • pwm74pwm74 Member Posts: 5
    It usually happens after it fires up again while being standby for a while. It never reads code while it is fired and circulating. Now it is reading E21(which also states to change board) a bit so often. Which i have to turn off and let it go through start up cycle. I gave in and ordered the control board. I figure the unit cost me nothing in the last 8+ years. Thank you for input and advice. 
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!