Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Rinnai RMFE 556 WTAP

Options
Icarus
Icarus Member Posts: 143
Not sure this is the right sub forum, but I’ll post it here and see.

My sister has a Rinnai RMFE 556 WTAP that is giving her (and me) fits. (Note, I am not a certified Rinnai tech, but I know my way around these having worked on dozens of them over the years. Also, there is no local installer/service company that has ever seen one. You just don’t see them in the Pac NW)

The heater has an intermittent code 11 (no flame/no gas). Much (or most ) of the time it will fire and sequence normally obeying the stat set points etc, and will work for days or weeks at a time. Occasionally, for no reason that I can find, it won’t light, and will fault 11. The common reason for that is no gas, bad igniter, or bad flame rod sensor. The flame rods and electrodes are essentially the same as the ones in the more familiar water heaters, and the sequences are exactly the same. I removed and cleaned the flame rod and the igniter electrodes (they were perfect) and it still acts the same.

The problem is every time I go to try to do a “service call” it performs perfectly over and over again. I have not checked the manifold gas pressure, and I also haven’t checked the continuity of the gas valve solenoids, but since it burns perfectly (when it burns) and I can’t “catch it” in a failure mode.

You can hear the valve click, the igniter click. I am at a dead end. My only remaining thought is perhaps a control board. New ones are no longer available. Any ideas where to go with this unit?

Thanks once again for all the great resources on these boards,

Icarus