Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Help! Live far from technicians....Beckett primary control stays in restricted lockout -new primary?

kdubraw Member Posts: 3
Hi everyone - I have been reading this site all day, and just want to say thank-you to all contributors.
I live about a 6 hr drive from the closest technician, so I thought I would post here first.
I have a Beckett 7184B burner - about 10 years old. I am a tinkerer and handyman, but certainly not an expert. I have tried holding the reset button (45 sec) to get me out of restricted mode (I get two flashing green blinks), but it just goes back to a green flashing light within about 30 seconds. There are no sounds from the motor or anywhere else, and certainly no oil being sprayed into the furnace. I have confirmed oil in the tank, the oil filter is a little dirty, but pretty good. I followed the beckett troubleshooting guide - I jumped the T-T thermostat connectors, cad cell seems okay (measured by ohmmeter, also tried reseting with cad cells disconnected), and there is power getting to the unit (fan works).
The guide then suggests I replace the 7184B primary control unit - This will take me a week or so to get, so I could try this, otherwise I will call the technician, although that may also take a week for him to find a day to come out.
Any other ideas, obvious or not obvious? Thank you for any help.


    HVACNUT Member Posts: 5,474
    Having the primary go into lockout means the reset button was pressed too many times. The primary is not the issue. It did what it was supposed to do.
    How did you check cad cell resistance if the burner wasn't running?

    If you never pressed the reset, and it locked out anyway, then I'd say the primary is faulty. Otherwise you'll need a Pro.
  • EdTheHeaterMan
    EdTheHeaterMan Member Posts: 6,710
    edited December 2019
    Assuming the control was operating properly until recent issue, the Control is probably bad. If So... Replace with newer R7284 with LCD display.
    You described the green light blinks, then you reset, then there is no motor, no ignition sound, "Nothing"... then 30 seconds passes and the green light flashes. It appears that the internal relay contacts for motor and ignition are not working. To test this, remove the orange wire from the control to the motor. Power the control so the green light blinks. Reset as usual when the green light is off, the motor terminal or orange wire should be getting power 120V. measured between orange wire (Motor terminal) and Common L2 .You should also get power between Blue wire (Ignition) and L2 and finally after a few seconds you should get power between purple wire (Valve) and L2 If you are getting power as described above, then the motor is bad. Replace it. If you are not getting power, the control is bad, replace the control.

    You might have wires or spade terminals pic from Smokey Mountain Emporium website

    Pic from SlantFin website

    That far away from help... do you have any old oil burner parts from a previous heater? Maybe a neighbor with old parts? There may be a temporary fix until the Pro can arrive.
    Edward F Young. Retired HVAC ContractorSpecialized in Residential Oil Burner and Hydronics
  • kdubraw
    kdubraw Member Posts: 3
    Thanks for all your help. I have checked voltage, and it seems okay, so I have ordered Beckett 7505B to replace the 7184B.

    Hope it works, and thank you!
  • rick in Alaska
    rick in Alaska Member Posts: 1,441
    If I am understanding what you did, you disconnected the cad cell and then it ran? If so, then there is a short in the cad cell which would keep the control from working. You would need to find out if there is a break in the line going to the cad cell, or replace the cell. If it did not run, then it is most likely the control.
  • mattmia2
    mattmia2 Member Posts: 8,857
    If you have voltage on those wires in the sequence @EdTheHeaterMan described, then the control is working properly and the motor is bad. If you were getting the right voltages then you should have at least got spark unless both the motor and xfmr are ok but there is a bad neutral connection to the burner or something.