Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Tekmar 370 issue?

Good morning. It appears I have an issue with my Tekmar 370 that controls my heat/DHW(sort of). I have 3 zone radiant, an indirect DHW tank and a Veissman 100 boiler controlled by the 370 with 054 RTUs and an outdoor sensor. The system is working but supply temp to the zone pumps maxes out at 88-90 degrees. I have gotten the temp higher by disabling DHW priority. No issues with DHW.

I had Tekmar support on the phone yesterday and he thought it may have been the temp supply sensor reading too low. I was able to find one in stock locally and swapped it out this morning with negative results.

The system is unchanged since last winter, other than replacing the Veissman ignition block. I had planned on an upgrade to the 403 with 532s. I hope I am not paying for procrastination.

Thoughts, advice? Thanks.

Comments

  • John Abbott
    John Abbott Member Posts: 355
    If you are so equipped check the ohms of the 10K sensors there is a chart in the tekmar installation instructions available online if your sensors read the ohms corresponding to the temperature from the chart it is most likely the control I had to replace one last week and that fixed the problem. If you are not a professional you might consider calling one those controls are very expensive and easy to troubleshoot if you have the appropriate test equipment.