Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Weil Mclain HE2. locking out occasionally!!!!!

Zenster111
Zenster111 Member Posts: 6
I'm dealing with a Weil McClain HE2 boiler thats been locking out occasionally. When it locks out "purge" led blinks. Cycling the on off switch restarts it and it runs without any problems until next time, usually when it's colder outside and there is a greater demand for heat. Cleaned burners, flue box on top, which by the way was clean as a whistle when I took the top plate off . The condition never changed. So I changed the pressure switch , then the blower assembly, still no change. Then I changed the module with a 1013-200 since the original Honywell no longer exists. Now the " limit closed blower powered " led flashes once it locks out and the blower motor cycles on and off in sync with the flashing led. I am never there when it happens, but the person took a video when it was acting up. Never saw any thing like it. The house never loses heat because the new module resets itself after an hour of being locked out, unlike the Honeywell module where you would know that it's locked out when the house got cold and you would have to run down to cycle the on off switch . So this leads me to believe that the problem still exists. Not with the pressure switch, but with blower fan powering up causing " purge" issue like in the original module. Major components have been changed , with pretty expensive parts list and the boiler is still not happy!!!!! running out of parts to change, anyone has any idea I would appreciate some input, thanx I'm advance

Comments

  • Docfletcher
    Docfletcher Member Posts: 476
    edited November 2018
    I'm no pro but you can check out this you tube video. Sounds like your problem. He takes the top off and vacuums it out.


  • Zenster111
    Zenster111 Member Posts: 6

    I saw that video. But that is not my issue. I did take off the top off, and it was as clean as a whistle.
  • Docfletcher
    Docfletcher Member Posts: 476
    Maybe obstruction in the inducer?
  • Zenster111
    Zenster111 Member Posts: 6
    took that apart, even changed the inducer, cleaned the exhaust pipe all the way.
  • Docfletcher
    Docfletcher Member Posts: 476
    edited November 2018
    Does it run when you bypass the pressure switch? It could be the inducer motor may not be getting up to speed consistently. Did you change the motor and inducer both? I'm guessing here. ?
  • Zenster111
    Zenster111 Member Posts: 6
    Just to verify that it was not the inducer / pressure switch problem, during a cycle I unhooked one hose (red one) from the pressure switch and the boiler would not even start. tried 2 times before it went out to lockout and green led and " pressure switch closed" led was blinking. That is one difference between the old module and the 1013-200 . The old module would display " purge" blinking light. The 1013-200 when it acts up blinks "limit closed blower powered" led and pulses the inducer motor, you can actually hear the relay click inside the module when it pulses . It's like the relay inside the module is not holding in to power the inducer. But when you shut off the boiler wait about a minute then turn it on, she runs like a champ till next time it acts up.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!