Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Argo ARM-6P Mystery

Options
prwiley
prwiley Member Posts: 2
I have an Argo ARM-6P (http://us.argoindustries.com/sites/default/files/ARM2P-ARM6P IOM.pdf) connected to my oil boiler. It is controlling 4 pumps/zones using 2,3,4,5. 1 is unused. As the heating season started I found that one zone was not working, the one my plumber installed last year. No matter how high the thermostat was set no heat came. I pulled the thermostat, a Honeywell programmable one, not sure of the model number. I find a red wire, a white wire, and a green wire connected to R, W, and C respectively.

At the ARM-6P at the boiler the red and white wires were connected to R & W for zone 5 and the green wire to the 24V terminal (not to "common") on the ARM-6P board. It's the only connection to the 24V terminal.

I jumped the R and W terminals at the thermostat mounting plate and heat came immediately. So, I assume a bad thermostat and replace the Honeywell the a Nest E.

I install the Nest E following the instructions, however, when I turned power on to the ARM-6P, the Nest E does not come on as it should. To test the Nest E, I connected it to a charger via its USB port and it came right on. When it said to connect it to the baseplate I did so, and it ran part of the setup routine, but then soon shut down with the message "must shut down to recharge battery" or words to that effect,

So I have to conclude that there is not proper power coming up from the ARM-6P. If I understand how it's supposed to work, I should be able to measure 24V between the R for zone 5 and the common connection on the ARM-6P board. I get 0.045V. Measuring between R and the 24V connection I get 0V.

I tried moving the green wire from the 24V terminal to the common terminal and the ARM-6P would not work at all for any zone. Moved the green wire back to the 24V terminal and everything worked as before, which to say the other three zones worked, but not 5. None of the other thermostats in the system use C.

So I am going to guess that the 24V transformer on the ARM-6P is bad, or the board itself in some way. I don't see any swollen caps on the board.

Can someone please explain what might be wrong, and suggest further troubleshooting steps, or next steps to repair.

Thanks for any help!

Comments

  • STEVEusaPA
    STEVEusaPA Member Posts: 6,505
    edited October 2018
    Options
    Your transformer is fine, otherwise it wouldn't work at all. If you jumped the baseplate and the zone came on, it's not the zone panel.

    From the manual...
    Your new Argo ARM control should work well with all standard and
    most programmable setback thermostats. In the event the programmable
    thermostat you are using causes the control board relays to
    chatter, you will require an external 24V power supply (transformer)
    and an Argo IR882 Isolation Relay. Please refer to the literature with
    the IR882 for proper wiring and transformer sizing.


    Page 22 may help.

    There was an error rendering this rich post.

  • prwiley
    prwiley Member Posts: 2
    Options
    Thanks Steve. Funny, I was reading that passage in the manual and then it dawned on me: the C wire is not needed in this application. I disconnected it at both ends and all works as it should.