Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Riello misfiring

michelizzi
michelizzi Member Posts: 3
I have a Columbia furnace with a Riello 40-F3 burner that had been working well since I bought this house. The other day I came back to a cold house and a locked out burner. I noticed the smell of burnt electronics and found a blown wire from the lockout switch and a popped capacitor, highlighted in the picture below.



Hoping that this was just a capacitor that gave up after 25 years or so of service, I ordered a replacement control box and switched over to the heat pump. When the new box showed up I installed it with the old CAD cell after checking it and going through the other voltage and resistance checks from the Riello troubleshooting chart. I bumped up the thermostat a few degrees and turned the furnace back on, then watched as it went all the way up to ignition, but cut out immediately after lighting. It would reignite every five seconds or so without locking out, but would never stay lit. I've posted a video to youtube just to make sure I'm not describing it incorrectly:



Nothing in this system has changed that I could point to as a cause. Everything seems to check out when going through the troubleshooting chart. I'm used to being able to figure things out for the most part and an oil burner doesn't seem like rocket science (although I know that experience counts for a lot) but I'm at a loss here. Does anybody recognize these symptoms or have an idea of something else to check, or should I just suck it up and call in for service?

Thanks,
Mike

Comments

  • lchmb
    lchmb Member Posts: 2,997
    check the coil or your tabs could be spread on the base..
    HVACNUT
  • michelizzi
    michelizzi Member Posts: 3
    The tabs look like they should all be making good contact and the coil seems to check out (1-2: 1387 ohms, 2-8: 1.3 ohms).
    Thanks for the suggestions!
  • newagedawn
    newagedawn Member Posts: 586
    did you purge the oil line? , you could need the cad cell also
    "The bitter taste of a poor install lasts far longer than the JOY of the lowest price"
  • newagedawn
    newagedawn Member Posts: 586
    did you check the solenoid voltage didnt hear it snap open
    "The bitter taste of a poor install lasts far longer than the JOY of the lowest price"
  • DZoro
    DZoro Member Posts: 1,048
    You may have a bad board, yes it can happen :/
  • Steamhead
    Steamhead Member Posts: 15,035
    Call a pro. This is not a DIY job. Where are you located? Have you tried the Find a Contractor page of this site?
    All Steamed Up, Inc.
    Towson, MD, USA
    Steam, Vapor & Hot-Water Heating Specialists
    Oil & Gas Burner Service
    Consulting
  • STEVEusaPA
    STEVEusaPA Member Posts: 5,452
    First you'll need to properly purge the oil line. If everything checked out as you claim, it's either air in the oil line, or too much combustion air. But that's if everything really checks out.
    steve
  • michelizzi
    michelizzi Member Posts: 3
    Thanks for the replies everyone. When I tried purging the oil line I could not see any air coming out with it, but it's still acting the same. The solenoid voltage checked out when I looked at it (following along another post on here related to checking a Riello). I think I'm going to go ahead and call in a professional on this one.

    Steamhead - I'm actually south of you in Fort Washington, MD. In the past my equipment was serviced by Southern MD Oil but I've had mixed results with them. I checked the contractor page for MD and found you and someone else in Baltimore. Is that too far for a service call?