Click here to Find a Contractor in your area.
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Riello Burner Series 40 F3 &F5 oil pump valve ohms reading

mercedesmercedes Member Posts: 37
I have Buderus 215/4 with Riello Burner Series 40 model F3 &F5. What happens the burner blower comes on in 12 sec the oil flame is on. Then about vary 3 minutes later the motor blower is still running and the flames goes out never causing a "lock out". The burner re-fires again. First thing I did replaced the nozzle no change. Checked the oil pressure when running properly it was 150 psi and when the flame cut out 70 psi. After researching the pump valve coil could be faulty. Found the spec. ohm reading for pins 1 & 2 = 1350 ohms and 2 & 8 should be around 1500. I checked the resistance of the oil pump valve and found pins 1 & 2 1470 ohms and pins 2 & 8 1.7 ohms. Replace the coil and found the new coil has the same resistance as the original coil. I still replaced the coil and no change. I would like to know the correct ohm reading and the purpose of this valve. Maybe the new coil is bad??? Trial fitted the primary control box too. Any question please ask and Thank you Dan

Comments

  • HVACNUTHVACNUT Member Posts: 1,228
    Flame is dropping out and it's going back into prepurge and trial for ignition. If your coil readings are correct, it's either the control box or oil related, i.e. plugged filter, strainer, high vacuum
  • CTOilHeatCTOilHeat Member Posts: 31
    Agree with HvacNut. Sounds oil related. Check oil flow at the burner. Could be as simple as a dropped firomatic wheel. Lots of those out there recently.
  • mercedesmercedes Member Posts: 37
    I have a tigerloop system. The oil filter has been changed in Nov 2016 and top of the tigerloop is filled with oil. I am not sure what is "dropped firomatic wheel"? is it the wheel on the adjustment to turn it to open and closed? thanks dan
  • CTOilHeatCTOilHeat Member Posts: 31
    It's the silver wheel here that allows oil to reach the burner. The threads are held in place by solder and sometimes breaks allowing the spring oil valve to close shutting off the oil supply to the burner.

    http://inspectapedia.com/heat/Oil_Valve_198_DJFs.jpg
  • STEVEusaPASTEVEusaPA Member Posts: 2,046
    Too much air.
    steve
  • rick in Alaskarick in Alaska Member Posts: 714
    I will bet it is direct vent with a fields concentric vent kit. When it is windy out, the flues gasses get pulled back in to the air intake,and because the burner has a fast response time, it goes in to recycle. Try disconnecting the air intake and see what happens.
    Of course, this is assuming it is using the concentric vent.
    Rick
  • mercedesmercedes Member Posts: 37
    I have checked the firomatic valve the wheel is fully engaged with the stem threads and I am able to turn the wheel and holds the stem in place. I checked the air shutter screw it is tight and set at 4.75 as per Buderus recommendation. also checked all flange screw for any additional air leaks seem to be ok. I found a past post on the ohm readings of the coil and my does not match. I just email Riello to see what are the spec for the coil. thank you for your suggestion, Still open to more..
  • mgdesrochersmgdesrochers Member Posts: 20
    edited March 2017
    Follow that flow chart that @BornForDying posted; it won't fail you and will keep you from throwing more parts at the problem. Given your description I would lean towards the primary control or an oil supply problem, but go through the troubleshooting to be sure.
  • mercedesmercedes Member Posts: 37
    The riello chart is just perfect. I am testing the cad eye now and will give the result and the final repair. THANK YOU
  • mercedesmercedes Member Posts: 37
    The solution to the boiler oil burner cutting out. Following the Riello chart:
    1)trial fit the cad eye NO CHANGE
    2)Found the coil to be within spec 1250 to 1400 ohms on the oil pump
    3)Replace the oil pump with the possibility the oil pump regulator is getting stuck NO CHANGE burner still go to pre purge stage.
    Oil pressure when running is 150 psi when the burner goes out 50 psi.
    I have a Tigerloop filter setup and replaced the F100-10 spin on filter 9/16/16
    I have decided to replace the nozzle, filter and recheck the oil pump pressure again.
    Solution:
    Found the oil filter had this brownish sludge in color. My oil company now deliver 20% Biofuel blend.
    I notice now that Tigerloop has a new unit for BioFuel but the filter is still the same F100-10 spin on.
    I am curious if the Biofuel now required more maintenance? or do I have convert to the Tigerloop Biofuel filter assembly.

    Thank to all for their help.
  • STEVEusaPASTEVEusaPA Member Posts: 2,046
    I'll say it again.

    Too much air.

    Or incorrect draft.
    Did you do a full combustion test?
    steve
  • mercedesmercedes Member Posts: 37
    I did a complete combustion test from smoke and recheck air draft setting and CO and 02 is still set at factory setting. I am now taking a sample fuel tank for any water and sludge. Will keep everybody posted.
  • newagedawnnewagedawn Member Posts: 549
    did you check the cad cell, sounds like that to me
    "The bitter taste of a poor install lasts far longer than the JOY of the lowest price"
  • STEVEusaPASTEVEusaPA Member Posts: 2,046
    What were all your combustion readings & draft over fire/at breech?
    Check your troubleshooting guide and follow the section that starts with:
    "Burner continues to cycle through pre-purge and ignition with immediate flame drop out".
    If you followed that exactly and you still have the problem, replace the control box and cad cell eye.
    But before you do that, just to humor me, while the burner is doing this running/losing flame, with burner cover off, take your hand and cover half the open area of the air band, just to see if the flame still drops out. If it doesn't then you probably have the air band open too far. If it is, and you close the air band and the smoke test is showing smoke, then you either have wrong/bad nozzle, and/or the head adjustment is wrong.
    steve
  • mercedesmercedes Member Posts: 37
    Combustion results Wohler 400 tester:
    Smoke clear zero
    02 6.2%
    CO 0 ppm
    Efficiency 85.9%
    CO2 10.9%
    Stack temp 376F
    Air temp 82F
    Excess Air 42%
    Stack loss 14.1%
    Dew point 116.2F
    Draft +0.6 from the plug next to the sight glass as per Buderus

    Cover the air band intake the flame drop out.
    Trial fitted the cad eye and controller
    Any question please ask.


  • mercedesmercedes Member Posts: 37
    I cut open the oil filter from the tiger loop. Bad load of fuel. Partially clogged oil filter was the culprit. Filter was only 4 months ago installed. see pictures.

    Thank you so much for all your advice and tips. I have learned from this experience.
    Dan
  • STEVEusaPASTEVEusaPA Member Posts: 2,046
    That is ugly for 4 months. Looks like 4 years. That's not just one bad load. You should consider at least treating every load of oil until the tank is clean. Or draining/cleaning the tank.
    You should also only buy heating oil, if possible, from a company that only gets heating oil directly from the refinery, not their own storage. And also not from a company that pumps out tanks and re uses heating oil.
    steve
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!