Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

No flow CI baseboard

DROC66
DROC66 Member Posts: 2
Have 10' of CI iron bb in hallway that will not heat. Zone is shared with two other bedrooms and one bath. Hallway I believe is last run on zone. I isolate all other bb on zone and still get no heat, I get water flow when I purge and feel heat about 1-2 feet on each end of the bb, but middle ice cold. I did not install job, just trying to help installing contractor. BB is heated by TT boiler and being pumped by Grunfos Alpha 1 pump, there is also mono-flow tee installed by BB. After all the trouble shooting I am thinking pump could be to small. Any suggestions would be greatly appreciated...Thanks.

Comments

  • delta T
    delta T Member Posts: 883
    how is the monoflow tee installed? scoop or venturi style?
  • Paul48
    Paul48 Member Posts: 4,469
    Baseboards can be near-impossible to purge, unless you can control the direction of flow. A friend that does service calls told me that when they got a call for no-heat on a baseboard loop, they automatically pumped the system down and added the necessary valves. As he said," it might take an hour and a half, but the other way, it might take 4, 5 or 6 hours".
  • DROC66
    DROC66 Member Posts: 2
    Scoop
  • delta T
    delta T Member Posts: 883
    There are specific requirements on exactly how you can install monoflow tees. You might want to look up what brand you have and see if you can find the installation instructions for it. They can be very finicky. Is the alpha in auto adapt mode? try taking it out and setting on a high fixed speed to see if that helps.

    purging air from monoflow systems can be tricky, though it sounds like you have a flow problem not an air problem. Is the tee installed on the return? how far away from the supply tee is it? Are you 100% sure the tee is flowing the correct way?