Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Rinnai R85i stopped igniting

bluwtrbluwtr Posts: 3Member
We've had our Rinnai R85i unit installed since 2007 without a fault. We have loved this unit. Recently we noticed that the hot water wasn't as hot as it should be. Background info--the installer did not install the flush valves. I finally made time to install them myself. Fast and easy. Turn water back on purged air from lines, turned on hot water tap and ZILCH. I called CS and they explained how to check the flow via the control panel. It reads 0. The tech then told me that I must have a faulty water flow sensor and water flow servo. I ordered the WF sensor yesterday (arrived today). I've installed the new unit and still no flow being read. I found out after the fact that the WF servo is a separate item to purchase (I thought it was all one unit). It is due to arrive tomorrow (overnight shipping). My question is two-fold: 1) what are the odds that installing the flush valves actually made the unit fail, 2) if the WF servo still doesn't solve the problem what is my next option? Had 11 and 12 error codes. The unit has had a few instances were it didn't light, but rarely at best.

Thanks for any and all help!

Comments

  • Tom_133Tom_133 Posts: 634Member
    Take pictures of what you got under the unit now.
    Tom
    Montpelier Vt
  • Aaron_in_MaineAaron_in_Maine Posts: 315Member
    Make sure to clean the screen on the cold water inlet to the Rinnai.
    Aaron Hamilton Heating
    [email protected] yahoo.com
    (207)229-7717
  • lchmblchmb Posts: 2,946Member
    could be something as simple as debris stuck in the servo. Probably silly question but did you clean the screen and the area just above where it sits?
    As far as the ignition issue, if this unit has never been serviced the electrodes probably need to be cleaned at minimum. From there, check the burner tray, check the incoming gas pressures...
  • bluwtrbluwtr Posts: 3Member
    Thanks for the replies.. Not sure what a pic of under the unit would do, but I can tell you it's just the gas inlet, cw inlet and hw outlet.

    I checked the screen and it was perfectly clear. I have a whole home filter system so that would take care of almost any particulate matter.

    I checked the old servo and it was clear. Pulled the turbine out and it spun just fine.

    According to the tech, because I'm not getting a flow reading at the controller then there will be no ignition. That makes sense to me but I will clean the electrodes just the same.

    After I install the new servo that is arriving this morning and by chance I still get a no-flow reading at the controller, what are my next options. I really feel convinced that it is a simple fix but I'm running out of options.

    Thanks all.
  • bluwtrbluwtr Posts: 3Member
    Well my father-in-law installed the servo for me while I was at work and still no flow reading at the controller. Is there a master reset or something? I'm calling Rinnai tomorrow and see what their take is now since their first fix didn't work. Looks like I'm going to have to call a service tech to come out. Any other suggestions before I do that would be appreciated.
  • Harvey RamerHarvey Ramer Posts: 2,200Member
    Hook a hose directly to the purge valve on the outlet and allow water turn it on for guaranteed flow through the heater. See what happens.

    Sometimes people get a cross connection between the hot and cold lines somewhere out in the system. This test will rule out that possibility.

    Check the wiring harness for possible loose connections.

    Ramer Mechanical
    ramermechanical.com
    To learn more about this professional, click here to visit their ad in Find A Contractor.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!