Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Logamatic display

TLM
TLM Member Posts: 38
I have a logamatic 2107 on a Buderus G115 oil fired boiler. Yesterday all was well. This morning- no hot water call. There are no lights or display. Power is good. Fuses are good. I put it in manual and dialed the aqua stat back to 140 from "AUT" any ideas? Do I have a faulty display or is it worse?
Mount Pleasant Plumbing and Heating Inc

Comments

  • BobC
    BobC Member Posts: 5,259
    Have you checked to see if there are fuses in the logomatic controller itself and that the controller itself is receiving power? If the controller is receiving power and there are no faulty fuses the units power supply may have failed. If you know anything about electronics look around and see if there are any suspect solder joints.

    Bob
    Smith G8-3 with EZ Gas @ 90,000 BTU, Single pipe steam
    Vaporstat with a 12oz cut-out and 4oz cut-in
    3PSI gauge
  • TLM
    TLM Member Posts: 38
    Fuses are good. If they weren't the burner wouldn't fire.
    Mount Pleasant Plumbing and Heating Inc
  • BobC
    BobC Member Posts: 5,259
    In that case it's either a failed component in the controller or a bad connection or solder joint.

    Bob
    Smith G8-3 with EZ Gas @ 90,000 BTU, Single pipe steam
    Vaporstat with a 12oz cut-out and 4oz cut-in
    3PSI gauge
  • TLM
    TLM Member Posts: 38
    Thanks. I'm going to call Buderus in the am to see if they've had any issues etc....
    Mount Pleasant Plumbing and Heating Inc