Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Embassy Industries Onex Boiler FILL issue

dazonex
dazonex Member Posts: 2
I have an Embassy industries Onex Boiler and the screen says FILL. i cant seem to get the boiler started. the psi is correct and the boiler is filled with water.

Comments

  • kcopp
    kcopp Member Posts: 4,088
    edited September 2014
    If the boiler....

    is filled and pressurized w/ water and you are still getting the fill readout then the pressure sensor is plugged w/ junk. I have run into this a number of times in the last 3 months on these boilers I have in the field. You can do 3 things. Jump out the sensor temporarily... replace it or clean it out
    PhilV
  • PhilV
    PhilV Member Posts: 1
    I had the FILL code on my Onex Boiler and it turned out to be the pressure sensor switch that was indeed "plugged with junk" It was a simple fix after I knew what the problem was. I talked with 4 to 5 plumbing experts and not one suggested the pressure switch. kcopp nailed it.
  • kcopp
    kcopp Member Posts: 4,088
    This is not just to Onex boilers. I have seen it w a few triangle tube units too. Water quality, water quality , water quality. IMO Everyone of these high efficiency units needs to be flushed, cleaned and have a good quality inhibitor added.... the magnetic filters would be an added help too.
    SWEI