Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Embassy Industries Onex Boiler FILL issue

dazonexdazonex Posts: 2Member
I have an Embassy industries Onex Boiler and the screen says FILL. i cant seem to get the boiler started. the psi is correct and the boiler is filled with water.

Comments

  • kcoppkcopp Posts: 3,353Member
    edited September 2014
    If the boiler....

    is filled and pressurized w/ water and you are still getting the fill readout then the pressure sensor is plugged w/ junk. I have run into this a number of times in the last 3 months on these boilers I have in the field. You can do 3 things. Jump out the sensor temporarily... replace it or clean it out
  • PhilVPhilV Posts: 1Member
    I had the FILL code on my Onex Boiler and it turned out to be the pressure sensor switch that was indeed "plugged with junk" It was a simple fix after I knew what the problem was. I talked with 4 to 5 plumbing experts and not one suggested the pressure switch. kcopp nailed it.
  • kcoppkcopp Posts: 3,353Member
    This is not just to Onex boilers. I have seen it w a few triangle tube units too. Water quality, water quality , water quality. IMO Everyone of these high efficiency units needs to be flushed, cleaned and have a good quality inhibitor added.... the magnetic filters would be an added help too.
Sign In or Register to comment.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!