Click here to Find a Contractor in your area.
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.
Need to contact us? Visit

Control Module Replacement Compatibility Question

winterjazzwinterjazz Member Posts: 11
I need to replace the control module Weil Mclain S9301A1001

on an HEII boiler. Instructions state that it's not compatible with a B&G 100 circulating pump but I have a B&G SLC-30. How do I know if it's compatible with that model?

Thanks, Barb


  • icesailoricesailor Member Posts: 7,265
    edited March 2013
    Pump Compatibility

    A Series 100 B&G is a three piece pump and has a high Amp Draw. A Taco 007 is a wet rotor pump with a very low Amp draw. I think that a B&G SLC-30 is a low amp wet rotor pump.

    The relay in the new control can't take the amp draw.

    If the pump looks like this, it should be fine.

    If it looks like this one, you can't. This is a Series 100 Pump.
  • unclejohnunclejohn Member Posts: 902
    Some where

    On your existing pump the electrics are listed voltage, cycles, and AMPS if your pump  is lower then 1.7 which I think is what a 007 is rated your ok. Anybody know for sure the 007 amp draw?
  • SWEISWEI Member Posts: 7,356
    Series 100

    Running load on these is not all that high, but they have a centrifugal clutch and a starter winding which has a large inrush spike.  It pops fast blow fuses in modern boiler controls every time.  Use a wet-rotor circ or add a relay.
  • winterjazzwinterjazz Member Posts: 11
    This is what is says on the pump

    Class-115V 60HZ 1ph

    Amp .74 Wat. 85

    I sure hope it's going to work with it. We're without heat and in the middle of a snowstorm. The plumber that tested it wanted three times what the part cost after telling me it 's a fifteen minute job. I just can't afford it. I appreciate your help.
  • icesailoricesailor Member Posts: 7,265

    If the pump will run by jumping out the motor but the boiler won't run or start, the control needs to be replaced. The control isn't cheap.

    If it is a HE II, it is almost as old as dirt and the control has served you well.

    If the service person has the control, he either has a supplier that stocks them or he has one that he has for such situations for sale.. Just because you can find it on the Internet for less doesn't mean he's "Ripping You Off". The last time I heard that, I told them that my house was warm, I took the control back to the supplier, paid a 10% re-stocking fee, wished the person health, happiness and long distance, and ate two hours of uncompensated time.

    You're lucky. I hope you don't stay cold for long.
  • winterjazzwinterjazz Member Posts: 11
    pic of the pump

    Pics of the pump
  • winterjazzwinterjazz Member Posts: 11

    I certainly didn't say he was trying to rip me off. I simply and honestly stated I couldn't afford it. I just don't have $600 right now after going through Hurricane Sandy here on Staten Island. I was lucky and had no water in my house but it did rip down trees and fences which I had to take care of. I know you guys are worth what you charge for your knowledge alone and I appreciate any answers that you give. I'm a 65 year old woman with a son who has cerebral palsy in a wheelchair. Not asking for pity but do you really think I want to be doing this myself? The boiler was installed 14 years ago.
  • icesailoricesailor Member Posts: 7,265

    It looks just like the one I posted. Its not a series 100 B&G pump.

    Your pump is compatible with the control you need.
  • Tim McElwainTim McElwain Member Posts: 3,893
    To the best of my knowledge

    the Honeywell S9301A - 1001 is obsolete and no longer made. The replacement is a United Technologies 1013-200 which can work with most pumps with no problem. Just make sure that the jumper which comes with the replacement is installed on the new board in place of the temperature sensor which typically is attached there.
  • icesailoricesailor Member Posts: 7,265
    Replacement Board:

    If you lived any near within reason, I could probably bum a used one for you. I'm a long way away.

    Write back Monday if you haven't been hooked up.
  • winterjazzwinterjazz Member Posts: 11
    edited March 2013
    I replaced

    the Honeywell S9301A - 1001 with the United Technologies 1013-200. I put the jumper on the temp sensor. The Honeywell S9301A - 1001 had a ground screw that held the board in place. The 1013-200 doesn't seem to have any ground. It comes with a new harness which is supposed to be changed because the plug is a different configuration but I see the wires are exactly in the same position and the the other holes are empty. I plugged it in and it seemed to work fine however, now the first light ( green power) and the next red light  (call for heat, circulators and blower powered) stay on steady all the time. Also, comes on and lights, stays on about five minutes even though it's still calling for heat and shuts back down to just those two lights on again before it warms the room or makes the water hot with the amtrol tank.

    Do you think it's because that harness must be changed?

    thanks so much. .
  • winterjazzwinterjazz Member Posts: 11

    so kind of you to offer but I do have the new board. Just need help getting it going. 
  • unclejohnunclejohn Member Posts: 902

    My friend are good to go.
  • winterjazzwinterjazz Member Posts: 11
    edited March 2013
    Do you have any

    ideas about my last question? It won't run run more than a few minutes so it doesn't get very warm in the house and the hot water is just lukewarm. It's like the zone is not opening. There are 4 zones one is an Amtrol tank. I had no problem with any of that before I changed the board. I would just turn the switch off and back on and it would reset the lock out.

    Could it be because I didn't change the harness? Or because there is no ground on the board now?
  • Tim McElwainTim McElwain Member Posts: 3,893
    The harness needs to be changed

    it comes with the module so that compatibiity between the system will occur. Before pulling the wires out of the shielded harness attach a piece of string so you can pull the wires back through the shielded (greenfield).

    The fact that only the power light and tstat circ light are on (but not flashing) also tells me there may be a limit switch open somewhere on the boiler.That is next in the sequence of operation.
  • winterjazzwinterjazz Member Posts: 11
    Unfortunately, changing the harness made no difference

    The wires on the harness were exactly like the ones I took off so nothing changed. Only the plug was a different config. but the three with prongs in them are still the same as the other plug.

    The green power and red light are still on when the boiler stops and still no hot water. The copper pipes after the zone valves are boiling hot. It seems like something is not opening to let the hot water go up. It runs three of four minutes and shuts off again.
  • winterjazzwinterjazz Member Posts: 11
    How bad is it

    to let it run with both lights on?  If I shut it off there won't be any heat tonight. At least it's keeping the temp about 64 degrees and I'll worry about it in the morning. thanks all and have a good night.
  • unclejohnunclejohn Member Posts: 902
    Most Likly

    A bad pump. Hard to belive no zone valves open.
  • winterjazzwinterjazz Member Posts: 11
    A bad pump that works fine with the old board attached?

      If I hook up the old board everything works fine until it locks out. The problem is that it locks out almost every time it shuts off so I had to keep switching it off and back on every 30 minutes or so.

    I think the zone valves do open because the pipes after the valves are blazing hot. It just doesn't run long enough for the hot water radiators to get very hot and the hot water is lukewarm.
  • Tim McElwainTim McElwain Member Posts: 3,893
    As someone said

    it sounds like a bad pump. If the pump is not running you will shut off on limit and that is evident from the light sequence you say you have.

    Why did you change the S9301 to begin with, what was the problem or is it the same problem.
  • winterjazzwinterjazz Member Posts: 11
    I changed it because

    the plumber who came here and ran some tests said that's what was wrong and said it would cost $600 to fix. I bought one from Pex supply.  I couldn't get it to work with the new module so I set about trying to fix the old one. I resoldered some of the loose parts.  I now see it was a few problems probably not the board. the main harness is faulty. when I move the wires going to the air pressure switch the red light came on after the blower motor started. After affixing that with tape to hold it in one place it ran all night without a lock out. So I will order a new harness and install it and see where to go from there. There is more to this story though. Changing the harness that came with the new module does nothing different than leaving the old one on. The plug configuration is six holes instead of four but the wires are the same and there are only three prongs that they fit onto. The new board can accept the old plug but the old board has no room for the larger plug so I had to change that back. The fact that the new board ran and made heat was surprising even with both lights on and some fault in the wires. But it only made heat up to a point and then shut  off and would not make hot water. I found a problem on the back of the new board. One of the circuits had burned. I'll have to see what happens from here. I appreciate all the time you fellows gave to help me with this and I will update as I go along.

    Sincerely, Barbara
  • Tim McElwainTim McElwain Member Posts: 3,893
    Barbara you are doing things that

    none of us would ever do. Re-soldering printed circuit board components is asking for trouble. I am more than sympathetic concerning your situation. You however need to stop and some how get a professional involved as something is shorting things out and that is just going to get worse as you go along.
  • icesailoricesailor Member Posts: 7,265
    Burned Circuit Boards:

    If you found six of that exact same boards, they might all have what appears to be e burned spot on the board.

    I see burned spots on  most boards and there's nothing wrong with them.
This discussion has been closed.


It looks like you're new here. If you want to get involved, click one of these buttons!