Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

My heating is not working possible Low water cut off device

eddyyeddyy Posts: 2Member
Hi, im a novice in heating but i have a williamson -thermoflo gwa and for some reason when i call for heat nothing fires up. i can see the flame on in the burner but nothing will turn on. the lights on my low water gaurd dog rb-24 are not on. usually its green or red but no lights. could it be that i have to replace the gaurd dog because it shorted?

Comments

  • Paul48Paul48 Posts: 4,492Member
    No Lights

    Not getting 24 volts, most likely. Probably a bad transformer, but it needs to be checked out.
  • eddyyeddyy Posts: 2Member
    No lights

    Yea i was thinking that there might not be any power going through, because i have 2 of these low water cut offs, one for the hot water going away and one from the returning. both devices have no lights on. I'll try using my electric pen to test if there is any voltage there.
  • unclejohnunclejohn Posts: 1,420Member
    What do you

    Mean "You can see the flame on " But nothing fires up? Is there a flame or isn't there?
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!