Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Baxi Luna 24Fi - 1.20 - Water pump continues to run with no flame

Hi,

I have a Baxi Luna 24fi also known as a Baxi Luna 1.20



I've done lots of research and had a few different service people out to take a look at the boiler, but just like most other people who have problems with these boilers, the service people are only interested in pushing you towards getting a new system installed.



The problem: A few weeks ago we noticed it was cold in the house and we had no hot water, so I went to have a look at the boiler and the neon light was illuminated.



After turning it off for several minutes and turning it back on it worked again.

However I left the closet door open so I could see if it would go off again etc.

It seemed to work fine, until several hours later the neon light was back on again.



When the top neon light gets triggered and is on, the fan get shut off, the flame gets shut off, but for some reason I can hear the water pump running.



Also after restarting and when it starts to work again the flame only appears to stay on for a few minutes max, then the flame shuts off, but I still hear the water pump running, then several minutes later the flame will reignite, this continues until at some point the neon light appears.



A friend with some experience with the same boiler recommended trying to replace the "Fan Pressure Switch". I changed it today but the problem still continues.



Can anyone offer any advise on pin pointing the problem?

Should the water pump continue to run when the burner goes off?



One last thing I wanted to mention, during the night and when the neon light is on, the noise inside the pipes isn't the same as in the past, it sounds like a tap is running and you can hear the water flowing and splashing. I know the water is flowing but I don't recall hearing it like that before.



Thanks

Craig

Comments

  • superdavesuperdave Member Posts: 149
    running pump

    Yes the pump should run even when boiler is in trouble mode. This is for safety to keep the heat piping from freezing. What about checking the ventori in the boiler vent to make sure it is note damaged or blocked up. Is there any other trouble lights blinking. What is the fan doing is it running up to speed and clicking the PSI switch? If the fan shut down you need to check if there is any power going to fan could be fan or the main PCB board.
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!