Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Utica UB95M-200

Options
kcopp
kcopp Member Posts: 4,452
Not super familiar w/ the units. Customer calls me last week w/ a LWCO lockout. Upon looking at the set up there are a few issues. # 60 Extrol is waterlogged... thus the PRV would drip and the boiler loses water. After a while you lose pressure.

Boiler is Nat. gas. 1 circ (15-58) w/ 3 Honeywell zone valves. System is piped "pumping away" w/ a Spirovent. System has large Cast Iron rads on 2 zones, 1 Fin tube zone..

 Simple fix swap out the extrol also notice that the outdoor sensor is disconnected and the boiler runs off limit.... I connect it and replace the sensor as it looked beaten on....

All is great for 4 days.... same thing happens again today. Lock out on LWCO.

Anyone have any clues?

Comments

  • Paul48
    Paul48 Member Posts: 4,469
    Options
    Questions

    Does the system have proper means of air removal? Is it a single zone with LWCO below a flow check? Just questions based on a problem I had with my system. I'd have to open the flow check, and get glug glug as the air released, and the boiler would fire.
  • kcopp
    kcopp Member Posts: 4,452
    Options
    no flow...

    checks. 3 zone valves.
  • kcopp
    kcopp Member Posts: 4,452
    Options
    Another odd...

    thing is that the boiler water pressure is fine. It remains at 20 psi. There are no leaks in/on  or around the boiler or in the radiators. The boiler was installed in 2010. No "issues" until this problem. Have any of you guys installed many/ any of these?
This discussion has been closed.