Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Honeywell burner control RM7897A1002 relay issue

NYCLandlord
NYCLandlord Member Posts: 20
Hi all,

I initially posted my problem in Strictly Steam, and now I think it might be the burner controller instead.  We recently converted from oil to gas, so a brand new system was repalced in a 20 unit apt building.  Our brand new Honeywell control RM7897A1002 for a Powerflame worked fine for 3 months and now we are getting lockouts for various fault messages.

Using the keyboard display, I was able to read the HISTORY of lockouts.

The very first was # 28 "pilot light failure", which I dismissed because it was on the 4th cycle on the first hour which I assume was during installation or testing.

Second fault one month later was 128 "internal fault", fixed by resetting.

One month later, fault 1 "missing purge card", fixed by resetting

2 days later, fault 128 again, fixed by resetting

next day, LOCKOUT, "SETUP NEEDED". fixed by going into setup menu to save and confirm zero prepurge time because system uses a 30sec prepurge card.

Once the system runs, it runs perfect.  So I'm wondering if the ghost might be in the controller.  "SETUP NEEDED" locks out the system, but is not a fault error, therefore not in the history.  What would cause it to go into SETUP?

 As I'm typing this, I wonder if the conflict is with the prepurge time of zero on the controller's memory vs. the 30 sec prepure card mounted on the controller as well.

Has anyone had a similar experience with these errors?

thanks.

Comments

This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!