Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Ultra 155 problems

Chris_Chris_ Posts: 1Member
I just had my WM Ultra 155 series 3 installed 4 days ago and I'm getting lots of ignition faults. I have gone through the troubleshooting section of my manual. The faults seem to be occurring at the end of the heating cycle. Any help would be greatly appreciated!



Chris

Comments

  • kcoppkcopp Posts: 3,394Member
    What did...

    your installer say? Was a combustion test done? Is it LP or Natural gas? If Lp was it converted right?

     Got Pix?
  • Empire_2Empire_2 Posts: 2,343Member
    Brand new

    The installer will take care of this for you, or should.  Kcopp is correct that set up and check procedures need to be performed.  I, myself only trust me readings and do not trust factory inspections.  Not to say the didn't get it right, but this way I know it's right.





    Peace



    Mike T.
  • remoremo Posts: 1Member
    Weil McLain ultra 155

    At the end om my heating cycle I'm noticing a slight drip and small puddle at the bottom of my boiler pan. The drip is coming from the Venturi. The boiler is draining fine and the condensate trap is clear. Any idea on why the water is showing up ?

    remo
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!