Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Problem connecting PTAC to remote thermostat

kiwandakiwanda Member Posts: 12
Still working on this PTAC in our addition:



I'm trying to improve a marginal situation by operating an older PTAC

with a remote thermostat rather than the unit's poor built-in controls.

Little direction is available from Amana (Goodman) or the manufacturers

of the two thermostats I've tried. Previously I had connected an old

Honeywell T87F (round, mercury) t-stat that I'd removed from another

location. It worked in cooling mode but not heat; it could not energize

the fan circuit in heating mode. Rather than rig up something with a

relay I decided to just grab a cheap modern t-stat that should work with

the PTAC.



Here's what I need to connect:



-Amana PTC093A35AB PTAC; single stage cool, single stage electric heat (no heat pump)



-LuxPro PSD011W thermostat



The wiring diagram for the PTAC is on page 17 here: <a href="http://becketthvac.com/manuals/Amana/PTAC/service.pdf">http://becketthvac.com/manuals/Amana/PTAC/service.pdf</a>



The diagram from the t-stat is page 2 here: <a href="http://www.luxproproducts.com/pdfs/PSD011Wa-022Wa_NL_ENG_Manual53.pdf">http://www.luxproproducts.com/pdfs/P...G_Manual53.pdf</a>



Here's how I connected these:



PTAC -->T-stat



GH =G

Y/W1 =Y

W2 =W1

R =R

C =C



But it didn't work. There is power to the t-stat, the fan will operate

manually, but the PTAC does not respond to a call for heat or cooling.

The idiot light on the control board signals either OK or thermocouple

error. I should note that I've tried this with J2 on the T-stat set to

"electric" and "gas" but neither work.



Any thoughts on how to proceed? I called Amana, who sent me to Goodman,

who left me on hold for 25 minutes. Haven't tried Lux yet, based on m experience with Honeywell they'll just send me back to Goodman.



thanks,

Kiwanda

Comments

  • cesar77cesar77 Member Posts: 4
    cesar hvac

    first need to add a jumper between RH and RC in the stat,and set the stat to electric heat on a call for heat the fan will run and the electric heat.
  • kiwandakiwanda Member Posts: 12
    » Problem connecting PTAC to remote thermostat

    It came with a jumper installed between RH and RC. Tried it with that jumped and set to electric. No dice.



    Thoughts? Should I check for voltage across Y and W with calls for heat/cooling to make sure the stat is working?  The control board on the PTAC flashes a "normal" code when not set to the remote stat, so I assume it's OK.



    -kiwanda
  • James Day_2James Day_2 Member Posts: 191
    check voltage

    I would definately check voltage across the thermostat.  See if on a call for cooling and heat you get 24v to C  across Y and W.  If you are not getting voltage then the thermosat is not working.
  • TechmanTechman Member Posts: 2,144
    PTAC

    Did you put the "t'stat/remote switch " in the remote position ?
  • kiwandakiwanda Member Posts: 12
    Got it working, thanks!

    Checked the fuse, jumpers, and all connections and finally got this working last night. While troubleshooting the setup I

    must have fixed a bad connection; when I reconnected it all after testing the t-stat it worked.







    I think the problem was likely the silly design of the main board on the

    PTAC. Rather than a terminal strip it just has 14 pins coming off the

    board. There's a little plastic housing that slips over the pins, and

    you must insert jumper wires with spring clips into the slots for the

    appropriate connections. I removed and reinstalled those after checking

    the everything and it magically worked.







    I appreciate the help with this. After failing with the old Honeywell

    unit I was sure this new Lux would work fine. Glad it eventually did;

    it's already evident that having a real t-stat controlling this unit is

    far better than the primitive dial control it was delivered with. As a result I'm going to keep it for a winter (we see -25F here) and see just how much it will cost to heat the guest suite electrically before I decide whether or not to invest in a gas replacement.







    regards,







    kiwanda
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!