Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.

If you've found help here, check back in to let us know how everything worked out.
It's a great way to thank those who helped you.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Pressure switch problem really sucks

Have a 10 year old 80% eff Lennox gas furnace that will not start and flash code and low voltage testing show a pressure switch fault.  Switch will not close with exhaust vent fan running.  The tech guy at Lennox says the switch should close at around a negative .4 inches of water column and bench testing (sucking on tube) with manometer and multimeter shows it does.  When connecting the manometer to the pressure switch port on the exhaust blower it shows a solid and steady neg .7" of water column.  With the manometer connected to the suction line with a tee it shows zero inches of column when the vent blower is running and if I pinch off the tube going to the switch the meter shows the .7" again but when released the suction drops back to zero.  Have tried two different switches, both new, one from Lennox and a Robert-Shaw genetic and all behave the same way, not working when hooked to the furnace but fine in the sucking bench test. 

The venting is not blocked and I've used new tubing to the switch.  I've even taken the original switch over to the neighbors house and connected it to his furnace (a York) and it works fine, his blower shows a neg .7" also.  I can jumper the switch out after the vent blower starts up and the furnace will light up and work properly until the t-stat shut it off.  However it will not restart for the next cycle with the jumper in place due to a safety built into the control.  Don't want no sticking switches.  Lennox guy says it must be the exhaust blower (doubt it) and to replace it.  Anyone else had this happen.  Thanks. 

Comments

  • don_9don_9 Posts: 395Member
    Inducer motor

    Sure sounds like the problem.Did you try a amp meter on the inducer motor to see if it was coming up to speed?

    Also was the blower motor running while you were doing your test? I've seen some crack heat exchanger do the same thing by putting a positive pressure in the hx.

    Let me be the second to say, its not the pressure switch.
  • Charlie from wmassCharlie from wmass Posts: 4,090Member
    Did you check the hose?

    Is the tubing cracked where it goes on the barb fitting?
    Cost is what you spend , value is what you get.

    cell # 413-841-6726
    https://heatinghelp.com/find-a-contractor/detail/charles-garrity-plumbing-and-heating
  • Empire_2Empire_2 Posts: 2,343Member
    Hey, Don? How have you been?

    Just to ad a thought, Make sure the port on induced draft housing is clear.  Often times it can plug up with crap.  I use a small Allen, or something similar to clear it. 



    Mike T......
  • sol rad mansol rad man Posts: 6Member
    that was it

    that was it, tried the small allen wrench myself the very first time as that is the answer 9 out of ten times, went in about and inch and stopped.  Banged it a couple of times and it wouldn't go any more.  Tech guy at lennox said they was a stop.  Wrong, checked out the adapter on the new inducer before installing and the wire when right thru.  Had to drill out the obstruction and it now works fine.

    Thanks to all
  • Empire_2Empire_2 Posts: 2,343Member
    Good News.

    Always good to hear the problem was solved.  Now you cal sleep good tonite with the furnace working.  When trouble shooting I always ask myself, "If something is not working, what has to happen to make it work?  Then see if the conditions are there to make it happen.



    Mike T.
  • don_9don_9 Posts: 395Member
    Hi Mike

    All is well and thanks for asking.Hope you are doing well also.Happy holidays.
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!