Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Burnham, Honeywell Aqustat power issue

Brian M
Brian M Member Posts: 1
Looking for some help. I have a Burnham V8 series oil heater controlled by a Honeywell Aquastat. The heater supplies water to 2 heat zones and for domestic hot water. The problem is that about once or twice a day the system shuts down. What I mean is, the zone thermostats are calling for heat but the Aquastat is dead. The relay is limp (no power) and the burner does not run. To fix it, I turn the breaker off to the unit and wait about 10 seconds. When I turn the breaker back on, the relay on the aquastat closes and the burner kicks on. Could this be a 24 volt transformer problem? I checked all the connetions and everything looks good. This is not a flame out issue. There are no alarms (flashing light) on the burner. It is like the system is dead. I have recently adjusted the set points on the aquastat. Right now the high is at 170, the low is at 145, and the dif is at 20. Any ideas?

Comments

  • dana_3
    dana_3 Member Posts: 57
    honeywell aquastat

    experiencing same problem with the honeywell 7184U-1004 aquasts. not locked out ,line and lo-voltage good into primary. just sitting there looking at you. not doing anything until you shut off power and turn it back on. honeywell at this point has said no problems so far, but has asked for the date code off the controls.
  • Robert O'Brien
    Robert O'Brien Member Posts: 3,537
    The

    7184 is a primary not an aquastat.I've heard the same thing about failures like this but have not seen it
    To learn more about this professional, click here to visit their ad in Find A Contractor.
This discussion has been closed.