Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

plugged panel rad?

kpc_40
kpc_40 Member Posts: 62
hooked to a manifold. the diverter is on temp. on there to test the flow... and it is open. Ty, I will check the valve. kpc

Comments

  • kpc_40
    kpc_40 Member Posts: 62
    anyone ever...

    run into this? In my own house OI added 3 panel rads to the 3rd floor. two are getting plenty of flow, 1 is not. I put a diverter valve on to bypass it and now get flow back to the manafold on the 3rd floor.Tried power purging through is but blew the prv. unit in 22 ser. buderus...ty,kpc
  • Big Ed_4
    Big Ed_4 Member Posts: 2,687


    I think I remember hearing when ordering, some of the deverters have a shut off valve. Check the sides of the valves.Also. ..... you only use deverters when you daisy loop the radiators. I would take it off with a manifold.

    The throttle valve may be stuck , plugged or NG ? v
    I have enough experience to know , that I dont know it all
  • van_2
    van_2 Member Posts: 20
    Possible Solution

    Any chance supply and return are reversed? This has happened to me with these rads. Sympton is very little heat. Swap feeds and all is good. Also diverter valves might not be adjusted correctly for % of flow that gets diverted vs gets into radiator. There is a red knob on the valve where you put the thermostatic valve. It can also be adjusted for flow. Finally, check thermostatic valve. These are great rads when working properly!
  • kpc_40
    kpc_40 Member Posts: 62
    that was ...

    my 1st thought. no. I checked. I think I have a bad rad. kpc
This discussion has been closed.