Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.
Click here to Find a Contractor in your area.

Testo 325M, Blank screen...

Options
Went to use my Testo 325M and nothing. New batteries and still a blank screen. Dropped it of @ Johnstone to ship it out for service.
It is only into 10 month's of use since I last had it calibrated and checked. Probably have done 40+ eff. test's with it and it's been trouble free for over 3 year's.

Would like to know if any one else has had this problem. I'm curious to know now, it will be 3-4 weeks until I hear from Testo.
Yes I have a fresh yellow filter and Bring it in the house this time of year. I also have the 120v adapter hookup still a blank sceen.

Comments

  • Jeff_92
    Jeff_92 Member Posts: 6
    Options
    Testo

    We have one and have had the same issues......getting ready to send it back for the second time. We also have two 330-1's and they are great!!! Much brighter screen with all of the information on one screen.

  • scott inM.E.
    scott inM.E. Member Posts: 68
    Options
    Testo 330

    Jeff, I have seen the 330's and will probably get one in the spring. I will keep my 325 as a back up.
    As far as Testo, I received an email about my post and they wanted to know the johnstone I had dropped it of at to get a bead on it when It came in for repair.
    That say's alot about the product and another reason this web site is a great tool.
This discussion has been closed.