Click here to Find a Contractor in your area.
Welcome! Here are the website rules, as well as some tips for using this forum.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

ultra display dead

Bill W
Bill W Member Posts: 2
Doing some 120V electrical work, turned off power to boiler room. On restart no display and blower runs constantly. Have 120V power to switch and to control mod. Is there a fuse? Where is it located? Any other ideas of what may be wrong? Thanks for any & all help

Comments

  • Tony_23
    Tony_23 Member Posts: 1,033
  • Mr Bill W.
    Mr Bill W. Member Posts: 10


    I looked under the cover and did not see any fuses. I also did not find them showen in the wiring digram. Location? front, back or in very rear near wiring strip? Polarity is OK. Very odd problem as it was working prior and the electrical work did not involve the boiler
  • Ron Schroeder
    Ron Schroeder Member Posts: 998
    They are listed as

    Control Module fuses I would check control module and wires to and fro. Two are listed though not shown in the book if not found call 219-879-6561 ask for Technical Services.
  • Mr Bill W.
    Mr Bill W. Member Posts: 10


    found and thanks for the help. have a great weekend all
  • Todd Schliphack
    Todd Schliphack Member Posts: 6
    Was it the fuse?

  • Mr Bill W.
    Mr Bill W. Member Posts: 10


    Yes the fuse was blown.
  • Leo
    Leo Member Posts: 767
    So who messed up?

    You stated that the power to the boiler room had been turned off for other work. The boiler should be on a dedicated circuit, did someone screw up?

    Leo
This discussion has been closed.