To get email notification when someone adds to a thread you're following, click on the star in the thread's header and it will turn yellow; click again to turn it off. To edit your profile, click on the gear.
The Wall has a powerful search engine that will go all the way back to 2002. Use "quotation marks" around multiple-word searches. RIGHT-CLICK on the results and choose Open Link In New Window so you'll be able to get back to your results. Happy searching!
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.

Ultra 155 problems

Chris_Chris_ Posts: 1Member
I just had my WM Ultra 155 series 3 installed 4 days ago and I'm getting lots of ignition faults. I have gone through the troubleshooting section of my manual. The faults seem to be occurring at the end of the heating cycle. Any help would be greatly appreciated!



  • kcoppkcopp Posts: 1,840Member ✭✭✭
    What did...

    your installer say? Was a combustion test done? Is it LP or Natural gas? If Lp was it converted right?

     Got Pix?
  • EmpireEmpire Posts: 2,319Member ✭✭✭
    Brand new

    The installer will take care of this for you, or should.  Kcopp is correct that set up and check procedures need to be performed.  I, myself only trust me readings and do not trust factory inspections.  Not to say the didn't get it right, but this way I know it's right.


    Mike T.
  • remoremo Posts: 1Member
    Weil McLain ultra 155

    At the end om my heating cycle I'm noticing a slight drip and small puddle at the bottom of my boiler pan. The drip is coming from the Venturi. The boiler is draining fine and the condensate trap is clear. Any idea on why the water is showing up ?

This discussion has been closed.


It looks like you're new here. If you want to get involved, click one of these buttons!