Click here to Find a Contractor in your area.
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.
Need to contact us? Visit

williamson steam boiler not working? Need help

I have a one year old Williamson gas fired steam boiler that was in the house I just purchased. It was working well for a week before the system stopped. When you jump the two thermostat wires the system starts and works fine. It had the old t87 round thermostat which I changed and still did not work. I changed the thermo wire all the way to boiler and still not working unless I jump the wires. I then changed the 24V transformer-relay and the same problem. I was getting low voltage readings before I changed transformer and now after the change readings are normal but system still does not work if I don't jump the wires. I don't know what the problem is????? 


  • What else could it be?

    In your post you said that when you jumped out the thermostat wires it worked. Did you jump them out at the thermostat? If you did then the only problem it could be is the thermostat. Hopefully, all the changes you made since then have not added to the problem.
    If the women don't find you handsome, they should at least find you handy!
  • genolegakisgenolegakis Posts: 3
    edited December 2013
    jumping the wires

    Yes, I did. I jump the wires right at the thermostat, where they hang out of the wall where the thermostat connects to them. By the way,  I have tried three different t87 thermostats. Should I try a different thermostat??  digital maybe??
  • JStarJStar Posts: 2,668

    What is the model number of the thermostat? What is the model of the boiler?
    - Joe Starosielec
    [email protected]
  • honeywell t87

    After all that I did, change thermostat wire from boiler to thermostat, change transformer-relay...test all lines with voltmeter...the 3 different t87 honeywells did not work when connected to the wires. Finally I bought a different brand manual thermostat and connected the two wires and l I HAVE HEAT.........damn t87 honeywell..will never buy another again
  • JStarJStar Posts: 2,668

    It was probably a power stealing thermostat, which does not work with boilers equipped with automatic vent dampers. Don't blame the thermostat...
    - Joe Starosielec
    [email protected]
  • Just by chance were

    the T87 thermostats T87F-1849 or 1859, if so they have to wired a special way as they were designed to replace SPST and SPDT (Series 20 ) thermostats.
This discussion has been closed.


It looks like you're new here. If you want to get involved, click one of these buttons!