Click here to Find a Contractor in your area.
In fairness to all, we don't discuss pricing on the Wall. Thanks for your cooperation.
Need to contact us? Visit https://heatinghelp.com/contact-us/.

Weil-McLain won't heat

HI-  I have a Weil-McLain natural gas furnace, installed around 1997.  Since the late fall, we have noticed that there hasn't been much heat coming from the baseboard heaters, but because we also have a gas fireplace, we didn't pay much attention until this weekend when the outside temp dropped below freezing.  Then we wanted all the rooms to have a heat source!



We checked out the furnace and it is completely cold.  We had a service person come out today.  He first tried replacing the ignitor because the board was flashing the  "vent" light, but that didn't fix the problem.  Now he thinks that the UTEC 1013-10 Integrated Boiler Control Board needs to be replaced. 



I think this is a really expensive part and the service person didn't seem very sure that replacing this part would fix the furnace.  Does anyone have any ideas for me?

Comments

  • JStarJStar Posts: 2,668
    WM

    Whatis the model number? Does anything happen or run at all?
    - Joe Starosielec
    [email protected]
  • Model GV-4

    Ah, yes, I should have said - the Boiler model number is GV-4.



    We tried turning the power off and back on yesterday for about 5 minutes to reset the system.  At that time the Boiler Control Board went through its startup procedure a few times, but got stuck and started blinking the "vent" light.  We heard some pumps coming on.  We can't see the whether there is a flame in the ignitor - but because the service person swapped that part out today and the furnace still doesn't work, I'm going to go off the theory that the ignitor isn't the problem.
  • JStarJStar Posts: 2,668
    Error code

    I din't see or remember any "vent" light code. Could it have been some other LED code?
    - Joe Starosielec
    [email protected]
  • Valve Light

    Looks like it is actually called "valve" light - sorry for the confusion.  I was going off memory and I should have verified before posting.
  • furnace seems to work but boiler dosent

    all of a sudden our heat registers stopped getting warm and now the house is freezing,furnace seems to be working but not heating the house,thinking it might be the boiler,it makes weird sounds and dosent stay on long enough to do anything,
  • Tim McElwainTim McElwain Posts: 3,849
    Need more information

    Is this also a Weil McLain GV model boiler?
  • icesailoricesailor Posts: 7,265
    Sounds like a:

    Sounds like a Warm Air "Furnace" with a broken belt or motor ans no air flow.
  • fixed

    it was a thermo Coupling , got it fixed :)
  • unclejohnunclejohn Posts: 861
    That makes

    No sense at all.
  • ok

    thermol it was ,whatever the spelling is
This discussion has been closed.

Welcome

It looks like you're new here. If you want to get involved, click one of these buttons!